Windows 2012 Server - Bartender Cannot Connect To Seagull License Server Folgen

Legacy Poster

We have a recurring problem on a Windows 2012 server.



- Periodically, a message appears on the machine stating :


BarTender: Warning Message #2401
Although BarTender cannot connect to Seagull License Server, your BarTender will continue to function normally for another 3 day(s).  However, after this grace period ends, BarTender will refuse to print or export printer code templates until a connection with Seagull License Server is reestablished.



- If I go into BarTender, a message sometimes appears immediately and also randomly if the application is left open stating:


BarTender: Information Message #1418
BarTender has successfully connected to Seagull License Server.


It will then sometimes close that message and the other #2401 will appear again.  Like it can find it, then cannot find it, etc..


- In BarTender, if I go to Administer > Licensing Setup and click the Test button, it sometimes takes up to 20s to successfully find the Seagull License server.  Other times (usually after this first try) it finds it immediately and shows the success message.


- If I ever try to restart the license server by stopping it, it seems to stop but the license server window normally hangs (not responding), and an error message appears:


Seagull License Server: Error Message #3611
The Seagull License Server could not be started as a Windows service.  Unknown Error.



I then try to start it using the green play button.  It looks like it is starting it, but the same error appears again.

I then wait for the License Server window to respond again (not responding) and click the play button one more time.  It starts immediately (almost like it was already running).


This only occurs on a

Windows Server 2012 Standard edition 64-bit OS

Bartender Enterprise Automation v10.1 SR4 build 2961


The License server and Bartender are on the same machine (not two different servers)


On the suggestion of Seagull IT, I have tried the following:

- unchecked the "Automatically Find Seagull License Server" checkbox

- Used an IP Address for the Server value

- Used a Machine name for the server value

- Changed the Port being used to 5183 or 5185 (from the 5160 value)


None of these have successfully fixed the problem.


In the Seagull License Server under Administer > Service Setup Service Options, I found that the Startup Type was Automatic (Delayed Start), so I changed this to Automatic.  This did not seem to help.


Also, under Administer Service Setup > Run Options, the setting is Service.  Should it be Application?

Does this version support Windows Server 2012 Standard?

Has anyone else seen this issue?


Any help would be appreciated.  If you need more information, please let me know.


3 Kommentare

Legacy Poster
Aktionen für Kommentare Permalink

Since it seems I have stumped everyone, maybe we can start with asking if anyone has successfully been able to run the license server and bartender on a Windows Server 2012 Standard machine without encountering this issue?


Should I possibly upgrade to Windows Server 2012 R2?


Can anyone at Bartender comment on this?

Legacy Poster
Aktionen für Kommentare Permalink

I sent in another support request for this issue due to a lack of responses here.  A Support Technician 1 from Seagull responded with this link -


Most of these suggestions have already been tried, as indicated in my forum post.  I went ahead and tried everything in this list.  Here are my results:

Install and Activate Seagull License Server 
- it was already installed and activated. I verified the version and build numbers matched on both the seagull license server and the bartender application.


Ensure Network Connectivity 
- the license server and the bartender application are both on the same machine. regardless of this, I went ahead and pinged the machine name and the IP address. Both worked. The IP I used was the private 172 IP address of the machine.  I tried both the IP and the Machine name (which was already be used), testing each individually.  Both had the same results.  The License server connects, sometimes immediately, sometimes after 15-30 seconds.  I still periodically get a 2401 message, as described above.  


Match Port and Host Name 
-- the License server had the Machine Name and Port 51XX. This is exactly what I had in Bartender for the connection. 
-- I changed the port to a different 51XX in both the license server and bartender. Then stopped and started the license server. Of course, the license server gave me all the error messages again (as described in my forum post), and took about 3 tries to restart. Once is started again, Bartender connected immediately, for about 10 minutes. Then it start taking about 15-30 seconds to connect to the License server again. Basically, I click on the "Test" button in the Licensing setup, and the message "Attempting to connect... " displays for anywhere between 15-30 seconds. It finally connects. 
-- FYI, BarTender is not crossing subnets. Again, they are both on the same machine.


Disable Firewalls 
-- I shut off all firewalls on the machine. This did not change anything, as it still was delayed in connecting the License server and still displayed the 2401 message periodically, like it was trying to find the license server.


Version and Edition Compatibility 
--As I indicated above, I did verify both the License server and BarTender are the same version and build.


So the problems I am still seeing are: 
-- Just doing a Test connect to the License server from the Licensing setup screen in BarTender will sometimes be immediate and sometimes take more than 15 seconds. It should be immediate, correct? as time goes on, I find that it sometimes won't connect at all and sometimes will lose the connection and go into trial mode.

-- If I try to stop and restart bartender, I get numerous error messages (as detailed in my forum post). It will take a couple tries to restart the service.


Can anyone provide feedback or suggestions ... or better yet, a fix?

Shotaro Ito
Aktionen für Kommentare Permalink

Hi - sorry for not responding it long time - I understand that there's some hardship setting up SLS on your environment - unfortunately I don't have a good suggestion for this case.


From Do you run SLS on AWS EC2 Windows instance?

BarTender 10.1SR4 is both compatible with 2012 server and 2012R2.

You can run License Server as Application (you need to login to the server by an user account to run the application though.)

To connect to local license server, in BarTender > Administer > Licensing setup, disable auto detect and specify "localhost" as primary server address.


I recon the problem is License server service is failed to start or is shutting down by itself, and that's likely caused by the environment (ex. conflicting other software installed etc).

That's possibly resolved by changing network port however apparently that did not work in your case. Carefully check windows event log (Application log, system log.)


I would try on clean OS environment to determine what application (or settings) would cause the issue.

First deactivate the current license server, 

Then prepare a clean windows image on the vm host (have install applications as few as possible), Install BarTender with License Server and activate to try.

If that goes fine, gradually add applications required.


Note that It would consume one activation count (BarTender license allows 3 license transfers. if that matters please contact to your regional tech support).

Bitte melden Sie sich an, um einen Kommentar zu hinterlassen.