History Explorer Unavailable For Other Users Folgen

0
Avatar
Legacy Poster

Hi,

 

I have installed the system database with the default settings, ie a local MSSQLServer database using Windows authentication.

 

And it works fine. That is, it works fine as long as I use the same Windows account as I used duing installation. But nobody else can access History Explorer. History Explorer will start by asking which database to use, and it will show that the current WIndows account will be used for authentication.

 

The best I can get is a message saying that 'The server principal (account name) is not able to access the database "BarTender" under the current security context.

 

I have searched through some Bartender documentation, and also a bit of MS SQL Server documentation. But I am apparently not smart enough to find it ;)

 

How can I give other users access to History Explorer?

 

Edition: Automation,
Version: 10.1 SR3
Build: 2954
OS: Windows 7 Enterprise [x64], SP1

 

Thanks

 

John

3 Kommentare

0
Avatar
Domingo Rodriguez
Moderator
Aktionen für Kommentare Permalink

If History Explorer is asking for credentials when starting, this isn't defined behaviour.

 

Once the "BarTender System Database Wizard" has been used to create a database and configure credentials, "HistoryExplorer.exe /autoconnect" can be used to connect to that database without a prompt for credentials, providing that the "BarTender System Service" Windows service is running. The /autoconnect command line switch causes HE to use the System Service's credentials:

1. The Start Menu shortcut created on install causes History Explorer to be started with the /autoconnect option specified.

2. When History Explorer is started with /autoconnect, it will try to obtain the user's Connection String for the database via the BarTender System Service.
 
So, if the form asking the user for database credentials appears when you start History Explorer, one of the following is probably true:
 
1. You did not start History Explorer it from the Start menu shortcut.
2. You do not have the BarTender System Service running.
3. You did not run the BarTender System Database Setup on your machine to configure a Database Connection/Connection String for the BarTender System Service.
4. There is some sort of Security issue preventing History Explorer from making contact with the BarTender System Service to ask it for the Connection String. Perhaps the BarTender System Service needs to be configured via the "Services" control panel with different account credentials such as a domain account which will allow the History Explorer to connect to it.
 
Besides this, if instead of Windows Authentication you would be using SQL Server Authentication, then no matter what user you're logged under will make use of the SQL Server credentials.
 
Please also check the below training videos:
 
 
0
Avatar
Legacy Poster
Aktionen für Kommentare Permalink

Hi,

 

Let me answer your questions:

 

  1. Yes, I used the shortcut in the Start Menu to start History Explorer. Windows hides some details about the shortcut, so I can’t see if the shortcut uses the /autoconnect switch. I manually created a new shortcut with the /autoconnect switch – and when I use that, I still get prompted to connect. I don’t know why the /autoconnect switch doesn’t work, but it is not much of a bother to click ‘Connect’ in the dialog. I will leave it at that…

 

  1. The BarTender service is running.

 

  1. My memory fails me a bit when it comes to how I set up the database. I must have used the Wizard, as this is the (only?) way to create the database. The database is there, and it works fine except for the blocked users.

 

  1. The Bartender service runs in the System account. I don’t know why the service won’t provide a useable connection string. It is possible that my computer has some setting preventing it from working.

 

I watched the training videos you suggested. The second video explains how to allow others to access the database. And that was what I needed to do. I used Microsoft SQL Server Management Studio (SSMS) to allow BUILTIN\Users to Connect, Delete, Execute, Insert, and Update. And with those settings anybody can run History Explorer.

 

In conclusion: I am happy with the way it works now. It does what I want it to do.  I am less happy with the amount of time and effort it cost me to get to this point. Maybe you want to revisit the installation procedure and the default settings, and maybe also the documentation, so people as stupid as me can get it going easier.

 

Thanks

 

John

0
Avatar
Domingo Rodriguez
Moderator
Aktionen für Kommentare Permalink

Thanks for the feedback John.

 

Perhaps a direct link to the training videos during the BT System Service setup would help to avoid these sort of configuration issues...

Bitte melden Sie sich an, um einen Kommentar zu hinterlassen.