Failed to Refresh the License Error
Symptoms
When trying to refresh your license from within Administration Console the refresh fails and you are shown the following error message:
Failed to refresh the license '[Support number]'. Details: The underlying connection was closed: An unexpected error occurred on a send.
Environment
BarTender 2019
Diagnosis
This is a known issue with BarTender 2019 due to the fact that the installed .net framework uses the older TLS1.0,
TLS1.0 and TLS1.1 have been deprecated and so, for security reasons, they are no longer supported by the BarTender activation server which is why the refresh fails.
Solution
Update BarTender
This issue only affects BarTender 2019 installations. In order to fix this, it is recommended that you upgrade to the latest version of BarTender. In doing so, you ensure that a newer version of TLS is used which is compatible with the activation server.
Update Registry
- Find the Registry Editor by typing regedit into the Windows Search and open it:
- Backup your Registry under File > Export in Regedit where you will be asked to specify a file name and a folder. Make sure that Export Range is set to All.
-
Select the below locations from the left-hand side menu and make the changes as indicated:
- Under HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\.NETFramework\v2.0.50727
add the key/value pairs:
SystemDefaultTlsVersions=dword:00000001
SchUseStrongCrypto=dword:00000001 - Under HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\.NETFramework\v4.0.30319
add the key/value pairs:
SystemDefaultTlsVersions=dword:00000001
SchUseStrongCrypto=dword:00000001 - Under
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\.NETFramework\v2.0.50727
add the key/value pairs:
SystemDefaultTlsVersions=dword:00000001
SchUseStrongCrypto=dword:00000001 - Under
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\.NETFramework\v4.0.30319
add the key/value pairs:
SystemDefaultTlsVersions=dword:00000001
SchUseStrongCrypto=dword:00000001
- Under HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\.NETFramework\v2.0.50727
- After saving your Registry modifications, restart your computer to ensure the modifications take effect.
- Open the Services app by typing Services into the Windows Search
- Find the BarTender Licensing Service, right click it and choose Restart.
Offline Activation
Alternatively, you can circumvent the issue by performing an offline activation of your license.
- You will first need to deactivate the license in Administration Console on the license server.
- Within Administration Console on the computer where the license was installed, click on Licensing on the left hand side, right click on the license in question and select Deactivate License.
- Once deactivated, you can follow the steps listed in the article Offline Activation to perform the activation.