License Server Isn't Updated After License Renewal
Symptoms
When a BarTender license is renewed, a license server refresh will be triggered to update its license information. This refresh is important since the license server will stop working if its license information is expired.
However, there may be circumstances where your license server is unable to refresh automatically. This may include firewall issues or because your server cannot connect to the internet.
Thus, if your license server fails to refresh automatically, you may receive an error stating that your license has expired despite renewing it.
Environment
BarTender 2019 and later
Diagnosis
Open Administration Console > Licensing > Current License and make sure that your license is not marked as expired in the License Expires column:
Solution
Take the following steps to resolve the issue:
- Make sure that your server is connected to the internet.
If your server is not connected to the internet, you can try Deactivating BarTender and then performing an Offline Activation. - Contact your IT Department and ensure your firewall settings aren't blocking the server.
- On the license server, open Administration Console > Licensing > Current License and refresh your license:
If this does not resolve your issue, don't hesitate to contact technical support for further assistance.