Problem Setting Up the BarTender Print Connector for Dynamics 365 Business Central
Symptoms
When trying to setup the BarTender Print Connector for Microsoft Dynamics Business Central for use with BarTender Cloud, you may receive the following error message:
Could not retrieve authentication endpoint. Check the URL and try again.
Environment
BarTender Cloud
Microsoft Dynamics 365 Business Central
Diagnosis
Double check the following:
- Make sure that the account being used with your print connector is setup correctly
- Make sure that the print connector has been registered in BarTender Cloud. See this article for more information
- Make sure that the following information is correctly entered in the print connector setup form:
- the Root URL: The base URL of your BarTender Cloud tenant obtained by logging in to BarTender Cloud and copying it from the address bar in your browser. The base URL will take this form:
https://YourOrganizationDomainID.Datacenter.bartendercloud.com
- The ApplicationID from your print connector registration in BarTender Cloud
- Username and Password for the BarTender Cloud you want to use with print connector
- the Root URL: The base URL of your BarTender Cloud tenant obtained by logging in to BarTender Cloud and copying it from the address bar in your browser. The base URL will take this form:
If all of the above is correct and the problem persists, try the solution provided below.
Solution
The problem might be due to the print connector being configured to disallow HttpClient requests. To allow them, follow these steps:
- Click the Search button in the top right and type Extension Management into the search box
- Select the BarTender Print Connector
- Make sure Allow HttpClient Requests is enabled
Once enabled, you should be able to complete the BarTender Setup.
If the problem persists, please reach out to our technical support team.