Is the Seagull License Server Backwards Compatible? Follow

Avatar
Samantha Petro

BarTender Content Team


Question

Can my newer version of the Seagull License Server work with my older version of BarTender?

Answer

BarTender 2019 and later

Yes and no.

A license server hosting a BarTender 2019 (or later) license will not be compatible with BarTender 2016 (or earlier) due to a protocol change

In BarTender 2019 and later, the license server is both forward and backward compatible. A BarTender 2019 client can connect to a BarTender 2021 server and vice versa.

BarTender 2016 and earlier

Yes. In BarTender 2016 and earlier, the Seagull License Sever is backwards compatible. However, the opposite is not true (newer versions of BarTender will not connect to older versions of the Seagull License Server)

Do you have feedback or questions on this article? We encourage you to post them on our Community Forums