BarTender Activation Error 1177: "BarTender Licensing Service was not detected on IP address:5160 port"
Symptom
BarTender's Licensing Wizard returns error message #1177: "BarTender Licensing Service was not detected on IP address:5160"
Environment
BarTender 2019
Diagnosis
- You've already determined that the Windows Service BarTender Licensing Service is running, and you've attempted to restart this service.
- You are not presented with alternative/offline activation methods at BarTender's Licensing Wizard.
Solution
Recommended Solution
Update BarTender 2019 to its latest Service Release, which can be downloaded from this link.
This is a known issue that existed in BarTender 2019 and that was fixed in Service Release 8 for BarTender 2019.
Alternative Solution
We highly recommend that you follow the recommended solution. If you choose the alternative solution, we recommend these steps to be followed by an IT admin.
This issue generally happens in environments where outbound traffic is blocked by a proxy server or something similar, and/or server is offline. You can get past this error and get to the Offline Activation option by doing the following.
- Navigate to C:\Windows\System32\Drivers\etc
- Create a new folder and name it "Backup"
- Copy and Paste the hosts file into that "Backup" folder.
Now:
- Use the Search option and search for Notepad.
- Right-click Notepad and select Run as administrator.
- From Notepad, open the hosts file at: C:\Windows\System32\Drivers\etc\hosts
- At the bottom, add the following lines and save your changes.
- 127.0.0.1 license1.seagullscientific.com
- 127.0.0.1 license2.seagullscientific.com
- Execute the BarTender Licensing Wizard again, and you will now get the "Try Browser Instead" option.
- Once the license has been activated, remember to use the backup of the hosts file to revert to default settings.
Internal Only Information
https://seagull/jira/browse/BUG-2834
https://seagullscientific.zendesk.com/agent/tickets/266714