Error 3418: The License is Expired at Print-Time
Symptom
While trying to print from BarTender Designer, you may receive the following error message:
Error Message #3418 The license [PKC] is expired. Please use a different license.
BarTender will not print or export printer code templates until this is corrected.
Applicable to
BarTender 2019 and later
Diagnosis
As a new feature introduced in BarTender 2019, Provisional Activation allows you the ability to transition from a prior BarTender version to the latest with minimized interruption to your existing production site.
Error Message #3418 occurs when a BarTender installation that is running on Provisional Activation has expired.
You may also get this issue if you have accidentally activated BarTender using Provisional Activation(e.g., activating two BarTender computers that are under two separate networks with the same product key code).
To verify if your BarTender is currently using Provisional Activation, open BarTender Administration Console > Licensing and check if the Current License is showing as expired under the License Expires column such as the example below:
Solution
To resolve this issue, you would need to re-activate the existing BarTender installation as a BarTender client by:
- Deactivate the BarTender license that is provisionally expired within BarTender Administration Console.
- Open BarTender Designer > Help > BarTender Licensing Wizard and activate BarTender through your existing License Server.
Additional Resources
If you are unsure which computer in your network is acting as your License Server, please see: How to find the BarTender License Server on your network in BarTender 2019