Apache Log4Shell Vulnerability Follow

Avatar

BarTender Content Team


Question

Is BarTender affected by the Apache Log4Shell Vulnerability?

Applicable to 

All versions of BarTender

All versions of Drivers by Seagull

Answer

Neither BarTender nor our drivers use the Apache software or the Log4j library so both are not affected by this vulnerability. The Apache listed on BarTender's 3rd party copyright information page is referring to the open source licensing type and not the actual Apache software or libraries.

More Information

Recently a vulnerability has been found in Apache's software. This vulnerability is rooted in the Log4j Java library and if exploited, would allow an attacker to use this vulnerability to execute shell commands remotely. If you have concerns about the vulnerability, you may want to consult your IT department.

Here are some external articles that provide more information about this vulnerability.

Internal only information

Please see DEVQ-5275 

Do you have feedback or questions on this article? We encourage you to post them on our Community Forums