ZDesigner Drivers & BarTender Licensing
Problem
BarTender's licensing model is duplicating a single network printer using a ZDesigner driver. Each computer that prints a label from BarTender will take up an additional slot on the license.
Diagnosis
The reason this occurs is because Zebra uses its own Port Type (the ZDesigner Port Monitor). In the Printer Properties > Ports settings, these settings will look like a normal TCP/IP connection:
Under BarTender's licensing system, this does not appear as a normal TCP/IP port. The printer location should be the IP address of the network printer, and the port should be 9100. Instead, under printer location, the computer name is displayed on which the printer is installed. The port displays as LAN_[Printer Name].
Note the difference between a ZDesigner driver (top) and a Seagull driver (bottom).
Applicable to
All versions prior to BarTender 2022 R8 when using Zebra ZDesigner Drivers for Zebra printers.
Solution
Solution 1
To quickly fix this problem remove the ZDesigner drivers and install Seagull Scientific Driver with the Network Printer option.
Solution 2
Uninstall the printer and use the Windows Printer driver installation wizard and manually reinstall the ZDesigner driver to bypass the Zebra wizard.
Solution 3
Follow the below steps to replace the port settings for the currently installed driver:
- Open Control Panel > Hardware and Sound > Devices and Printers, and right-click your printer. Select Printer Properties > Ports > Add Port > New Port > Standard TCP/IP Port:
- Type the IP Address of the printer. You shouldn't have to enter anything into the Port Name field. This will create a new port entry in the port list.
- Select your new port:
- The ZDesigner Driver will continue to work normally, but now it will work correctly with BarTender Licensing.