Installation Error: "Do you want to allow this app from an unknown publisher to make changes to you device?" Follow

Avatar

BarTender Content Team


Symptoms

You may receive the following warning message when trying to install BarTender. This is usually due to the root certificates being outdated on the system where BarTender is installed.

mceclip0.png

 

Solution

To prevent this error from occurring, please try the following.

  1. Make sure Windows is up to date.
  2. Check if the certificate is present by running the following PowerShell command:
    
        Get-ChildItem “cert:\” -Recurse | Where-Object { $_.Thumbprint -eq “ddfb16cd4931c973a2037d3fc83a4d7d775d05e4” } | Format-List
        
  3. Run the following PowerShell command as Administrator to update the root CA certificates on the system, which should update the Digicert G4 root CA and fix the issue.
    
        certutil -generateSSTFromWU roots.sst
        powershell
        $file=Get-ChildItem -Path roots.sst
        $file | Import-Certificate -CertStoreLocation Cert:\LocalMachine\Root 
        

Do you have feedback or questions on this article? We encourage you to post them on our Community Forums