Skip to main content

Search

Search

Support for .NET 6.

Comments

7 comments

  • Avatar
    Xabier Clemente
    Moderator

    Hello Rene,

    Thank you for reaching our Forums with your query.

    BarTender 2022 currently ships with .NET 5.0.17. BarTender Designer uses .NET 4.7.3, which is still under support, however, BarTender's Integration Builder application and other automation components use .NET 5.0.17 and are dependent on this version. In short, using .NET 6 will not work.

    That being said, support for .NET 6 is an open feature request and is currently on the roadmap for our Development Team. We don't have an exact ETA on the feature implementation, however.

    Let us know if there is anything else we can do you for.

    0
  • Avatar
    Rene Elizondo

    Hello,

    • Looking at the .NET 5.0.17 link you referenced, there is a big note there that says the version is no longer supported. Are you guys aware of that?
    • Could you please tell me the difference between:
    1. BarTender 2022 (.NET 5.0.17).

    And

    1. BarTender Designer (.NET 4.7.3).
    2. BarTender's Integration Builder (.NET 5.0.17).

     

    Thanks.

     

    0
  • Avatar
    Xabier Clemente
    Moderator

    Hi again Rene!

    Yes, we are aware of that, and as previously stated, support for .NET 6 is an open feature request and is currently on the roadmap for our Development Team. Regarding your second question, different BarTender companion applications use different .NET versions, BarTender 2022 comes with a .NET installer that accounts for all applications and their different versions, that installer is for .NET 5.0.17.

    You can learn more on the subject here.

    0
  • Avatar
    Simon Rothwangl

    Hello,

    how is the state of the .net 6 support?

    Best regards

    Simon

    0
  • Avatar
    Peter Thane

    This has just been added in 2022 R7 that has just been released.

    From the Release Notes:

    • Note, the BarTender installer only installs the required .NET 6 dependencies. If there are any existing .NET 5 (or older) components installed on a system from previous installations, they will have to be manually uninstalled if desired. The BarTender installer will not automatically uninstall any previous .NET Core components and update them to .NET 6. This is because in some rare cases, users may have other applications that use and rely on older .NET components.
    0
  • Avatar
    Jonathan Pugh

    I just installed 2022 R7 and all of the .Net DLLs found in the SDK directory are compiled from .Net 4 so they are not compatible with .Net 6 applications. Does the Bartender SDK support .Net 6?

    0
  • Avatar
    Bernhard Bretterbauer

    Hi guys,

    I am confused. I just tried to implement the SDK 2022 R8 into a .NET 6 application. Doesn´t worked.

    these are the dll´s provided within SDK folder:
    It seems the shipped dlls are still using .net Framework 4.7. Isn´t it? Does somebody use it with .NET 6?

    0

Please sign in to leave a comment.