Prevent Duplicates Records Msaccess Follow

0
Avatar
Legacy Poster

I am using microsoft access as a database. There are duplicate records in the database. In the Bartender database setup screen, options Tab, Records, Allow Duplicates Check Box, when I have that option checked bartender prints the entire field with all the data, the problems is it prints the duplicate records as well essentially doubling or tripling the print job. When unchecked it does not print duplicate record, but cut the data short printing only printing a percentage of the field.

Please send any ideas as not to print duplicates.

1 comments

0
Avatar
Michael Toupin (mtoupin
Comment actions Permalink

[quote name='Darrenb' timestamp='1344464109' post='3030']
I am using microsoft access as a database. There are duplicate records in the database. In the Bartender database setup screen, options Tab, Records, Allow Duplicates Check Box, when I have that option checked bartender prints the entire field with all the data, the problems is it prints the duplicate records as well essentially doubling or tripling the print job. When unchecked it does not print duplicate record, but cut the data short printing only printing a percentage of the field.

Please send any ideas as not to print duplicates.
[/quote]

Make sure that you have a sort enabled in the Database Connection Setup window. Access suppresses duplicates based off of the sorted field, so if there's nothing specified, you may see an incorrect result.

To enable a sort, go to File, then Database Connection Setup. Select the 'Sort' tab, then select the field you'd like to use, and click the arrow to move it to the right side of the window.

Please sign in to leave a comment.