Printer Not Seen By Maestro Follow

Legacy Poster



we are working on a project to manage printing of labels from our homemade labeling management application using BarTender Commander with socket+BTXML. The printing part works great but I cannot manage to have the printer status for the job. I only receive jobCompleted="false" and LastJobStatus="Creating".


I've seen that I must use printer maestro for commander to be able to retrive printer status and send it back through the socket.

So i did it and followed those posts for configuration :


The first problem I have is that I cannot access the status monitoring tool option of the driver when the printer is installed with Ethernet because the button is disabled.

This will be a problem for us because all printers are installed with Ethernet in the factory (we use CUPS and .prn files at the moment)


I tryed to have it work via USB anyway but still I'm having troubles.

With USB I could follow instruction and setup all as required in previous posts but Printer Maestro does not see my printer, then I have no monitoring on it and commander cannot send the job status back.


My configuration is :

 - windows 7 enterprise 64 bit

 - Bartender full trial suite (we plan on using Enterprise Automation edition) Commander and Maestro are started on the same host the printer is connected to

 - printer is a Toshiba B-EV4T


Can you please help me solve this problem ? I must have it work with Ethernet, any workaround allowing to know if the print job completed successfully will be OK.







Legacy Poster
Comment actions Permalink

Hello there,


After almost a month of digging, this problem is finally solved!


The problem was that on my print server there were some other printers installed with HTTP. Those printers are managed by CUPS on our network so HTTP is the most simple way to use any printer on any host.


Problem is that Maestro did have issue at some point with these printers, preventing it to display and access any printer.


The solution I used was to remove every printer previously installed, install the Toshiba printer and restart Maestro service. Then every thing works as expected.


I'll try to find a way to have both BarTender and CUPS managed on the same print server but at this point my main problem is solved.


Many thanks to Seagull support team guys who helped me solve this issue.




Please sign in to leave a comment.