Create Bartender Instance And Spooling Time Follow

0
Avatar
Legacy Poster

I am having a big issue when creating a new instance of Bartender from the .NET SDK.
I have noticed that if I compile and run the application I wrote from the local administrator account, it has no problems.
But any other account in the domain, when the application opens, its takes a long time to load the form because I open a new bartender instance at that moment. The application sometimes runs almost immediately but sometimes it can take up to 10 minutes or even more, by that time the application its frozen and unresponsive. Again this only happens when I run this from a domain account. Now I have make sure that the domain account is in the Administrators group in the machine, and also I have tried editing every bartender-related permission in the DCOM objects, the executable, the label format, the folders, virtually everything and nothing seems to work. Lately I have been reading the documentation and found out you can actually force the account that opens bartender thru a WindowsIdentity, however this option seems to be only available in the C#, unfortunately for me all my code is written in VB. I have also tried changing the user that open the component in DCOM configuration to the Administrator account, but the problem remains.

The second issue is that even when sometimes I get it to work, when printing the first label the label appears in the printer but the details say "Spooling" and it never prints, the application hangs and become unresponsive. I know there are ways to prevent frozen app if the label couldn't be printed, but I do not implement them because it always fails. If I have look and can get the application to open and the first label to print, it works very well, but its really hard to do that.

As explained before, I have tried with permission configuration I have found, but the problem persists. Needless to say I cannot run the application from the Administrator Account, first because its against the company policies and second because my application has to have access to some shared drives. The clase I have written to print its very simple, but I still can get it work. Has anyone else come across this issue? I am very frustrated as I have been trying to fix this for the last two months without any success.

Please advice if someone as an idea on how to solve this issue, it would be very much appreciated.

Thanks

1 comments

0
Avatar
Shotaro Ito
Moderator
Comment actions Permalink

Don't have a very good idea.
By random firing - try disable certification revocation.
For the login user, Internet explorer Tools menu->Internet Options->Advanced->Security Node->Uncheck [Check for publisher's certificate revocation]

If this works, make sure your .net Framework 2.0's service pack has been applied.
Once .net framework 2.0 SP2 or 3.5SP1 has applied it should back to normal when you enable the certification check.

Please sign in to leave a comment.