Maestro Error Connecting To Remote Computer In Workgroup Follow


Does any reader of this forum have a similar experience which was resolved? Working with support this evening who is escalating this. If someone in support can attach this to my case, I would appreciate it. The attached screenshots may help.


Maestro reports "Could not connect to computer *****: A remote side security requirement was not fulfilled during authentication. Try increasing the ProtectionLevel and/or ImpersonationLevel"


According to Microsoft support, given the background information, this is a service connect failure message for the service attempting to contact the remote service. It occurs when both machines are in the same workgroup and a domain is not in use. That matches the configuration.


Windows 7, 64 bit server system which has Automation edition installed and a local printer trying to use a printer installed on a Windows XP SP 3, 32 bit system which temporarily has trial edition of Enterprise installed.


The end goal is enabling an application running on the server to access and print to the remote printer. This works without problem on domain networked systems and a workgroup test bed which has Windows 7, 64 bit Enterprise to Vista 32 bit which does not have any Bartender software on it (working to get Windows XP system for testing).


First test, remote system firewall off, anti-virus off. default installation which means printer maestro service is running as local service account. Server system has anti-virus off, port 7170 inbound/outbound permitted. remote system has printer tested to work locally and then set to shared. server system browses to remote system and initiates connect to shared printer. Connect succeeds at the windows level and remote printer properties are now visible and correct on server. License server on server shows remote printer/system seen and I checked keep. Maestro on remote system sees server system, but not its printers. Server system does not see remote system and gets error attempting to connect.


Second test, tried setting both systems maestro service to run under named local account with administrator privileges and restarted services. re-started Maestro GUI and no change on either system.


Confirmed that both systems have same user account (member of administrators) and password that can be logged into. Shutoff firewall on server, retested, still fails.


Third test, stopped maestro on both systems. used bartender on server to print to remote printer; works fine!


Fourth test, installed application which uses .NET SDK. Remote printer is not listed in printers collection!



Levi Hargrove
Comment actions Permalink

This may have been a legitimate permissions issue and or/ a limitation of the Automation edition. The permissions issue is detailed by the original post above, and the attachment with this post shows a screen shot that disclaims the difference between the Automation and Enterprise Automation edition in regards to the Printer Maestro.  


Here is the full link to it:


There are many articles on the internet on adding a network printer to a local port, using a local driver, here is one of them:


This issue is resolved. 

Legacy Poster
Comment actions Permalink

Maestro is unneeded and a "red herring" in this issue. Support went online with me to the problematic system and solved this as follows.


The resolution apparently is that the Automation Edition requires a different way of seeing the remote shared printer. Remote printers are supported in this edition and the remote printer was seen by the license server both originally and now with the different way of connecting it.


The solution was to create a port in add printer first as  backslash backslash server backslash device (posting with backslashes is not permitted here?) and then add the printer locally using that port rather than allowing the browse network and add printer connection function doing the same thing its way. This caused the Automation Edition to see the printer as local even though it is shared. Once the printer was "visible" in Maestro, it was also visible to our application which uses the .NET SDK printers collection. This was not an issue with the network attached printers which we also use.


Thanks to bartender support for the resolution!

Please sign in to leave a comment.