Sdk & Bartender Versions (Gac) Follow

0
Avatar
Legacy Poster

Having some issues with the BarTender .Net SDK. I created a program that uses the SDK and it works fine. The version the program was created against was:

Edition: Enterprise Automation Trial

Version: 10.0

Build: 2821
OS: Windows 7 Professional [x64], SP1

 

I created the program using the trial version as I do not have a printer setup for my development environment. However, the program works like a charm when installed on a computer within the company. That computer is using the same version/build and a licensed/activated version of Automation. Again, for this computer it is working fine.

 

So, here is where the trouble comes in. We recently purchased a second computer for creating labels and a new copy of BarTender. The new copy of BarTender is:

 

Edition: Automation

Version: 10.0 SR4

Build: 2868

OS: Windows 7 Professional [x64], SP1

 

When we try to install the program I created on this new computer it says that it is "Unable to install or run the application. The application requires that assembly BtSystem.Client.Version 10.0.0.1 be installed in the Global Assembly Cache (GAC) first."

 

Upon checking the GAC I can see that the version on the new computer is 10.0.4.1.

 

My questions are:

1) Why isn't the newer 10.0.4.1 version backwards compatible with the older 10.0.0.1 one?

2) Is there a work around for this?

3) Do I need to upgrade the trial version on my development PC and the version on the PC the program currently works on?

 

Thank you.

2 comments

0
Avatar
Gene Henson
Comment actions Permalink

Let me first make a note about our versioning.  The two version of BarTender that you specify above are actually just different service releases for the same version.  That means that your version 10.0 Product Key Codes can be used with BarTender version 10.0 SR4.  It may not be necessary for you to install 10.0 SR4 on all of your computers if you’re not experiencing any other problems on them, but you do have that option if you want to maintain consistency across your organization.

 

Now, on to your questions:

  1. Actually, they are backwards compatible.  We generally recommend that you develop your application around the lowest level BarTender that you plan to support.  In this case, you’ve developed your application around 10.0, so it should (but obviously is not) be fine running on 10.0 SR4 (and later).
  2. We’re not sure what’s going on here yet.  We’re doing some checking on our end and we’ll get back to you on this.  You can also call or email our support department directly for faster help as we may need to take a look at your setup in Visual Studio.
  3. See my above comments, it’s generally recommended to develop to the lowest version you plan to support, but in your scenario you do have the option to standardize to 10.0 SR4 across your organization at no cost.
0
Avatar
Michael Toupin (mtoupin
Comment actions Permalink

We've done some testing and have identified the issue here.  What's happening is that when you're publishing your application is that Visual Studio defaults to making the dependent files prerequesites in the ClickOnce deployment application.  

 

To resolve that, prior to publishing your application, select 'application properties' then select the 'Publish' tab (it may be hidden, if so select the 'more' arrow at the bottom).  Then select 'Application Files', that lists all the files it's marking as prerequisites.  Select 'Exclude' for any ones starting with BT or Seagull.  Then when you build your application it should not lock them to the version.

Please sign in to leave a comment.