Leading Zero Upc's From Excel Follow

0
Avatar
Legacy Poster

I have Bartender V 8.01. We use Excel for our databases. We now have to print some UPC's labels where the 12 digits UPC starts with zero. Because the number starts with zero I have to set Excel to text format but when I do that Bartender doesn't recongize any number exists. I've tried most other Excel formats for the cells but all still with same result. How do I get Bartender to recognize the zero?? What is the secret??? I have read through all the forums on anything similar and my only guess is that I need to go to More Options, Use VB Scripting and then click edit Functions and Subs or edit On Process Data and type some script. What is the script? Thanks.

2 comments

0
Avatar
Domingo Rodriguez
Moderator
Comment actions Permalink

Microsoft Excel was not designed to be a true database. When connecting to Excel,BarTender uses the Microsoft JET Driver, which was originally designed for Microsoft Access. One of the conditions of the JET driver is that each field (or column in your spreadsheet) must have a data type, just like the columns in Access would have data types. Since Excel is not a true database, the fields do not have any inherent data types. Instead, the JET driver takes a “best guess” at what the data type for a column is.

A possible quick fix would be to save your Excel file as a .CSV (Comma separated value) document, and then connect to this CSV file from BarTender's database connection setup dialog by using a "text file" database platform instead of an Excel one.

A different workaround would be to set a "Minimum" number of characters under the properties dialog of the BarTender object in question by selecting the "More Options > Minimum" dialog. You would set a minimum of 12 digits, and pad on left using 0 as the pad character.
0
Avatar
Legacy Poster
Comment actions Permalink

[quote name='Domingo - Seagull Support' timestamp='1351684787' post='3610']
Microsoft Excel was not designed to be a true database. When connecting to Excel,BarTender uses the Microsoft JET Driver, which was originally designed for Microsoft Access. One of the conditions of the JET driver is that each field (or column in your spreadsheet) must have a data type, just like the columns in Access would have data types. Since Excel is not a true database, the fields do not have any inherent data types. Instead, the JET driver takes a “best guess” at what the data type for a column is.

A possible quick fix would be to save your Excel file as a .CSV (Comma separated value) document, and then connect to this CSV file from BarTender's database connection setup dialog by using a "text file" database platform instead of an Excel one.

A different workaround would be to set a "Minimum" number of characters under the properties dialog of the BarTender object in question by selecting the "More Options > Minimum" dialog. You would set a minimum of 12 digits, and pad on left using 0 as the pad character.
[/quote]

Thank you! Problem Solved!!

Please sign in to leave a comment.