Zebra Zxp Series 7 Print Task Disappears From Queue Without Printing Follow

0
Avatar
Legacy Poster

We have recently obtained a Zebra ZXP Series 7 card printer for printing access badges, and set it up in Windows 8.1 using USB with the Seagull 7.4 drivers. The driver setup utility correctly identified the printer, and in BarTender, I can select it as a printer for my card template. However, when I print the template, nothing happens. When I open the queue, the print jobs appear momentarily and then vanish without printing. If the printer is in STANDBY mode, the printer warms up and goes into READY mode, but nothing else happens. Nothing shows up in the Windows Event logs. It just seems like the print jobs fall into /dev/null. If I go into Print... -> Printer Properties... -> Tools -> (Action dropdown) -> Read Printer Information..., I get these results:

 

Printer
 
Printer Model:    ZXP Series 7
Printer Serial Number:    310157318
Printhead Serial Number:    58-70150
Firmware Version:    FZ7MG.03.00.00
MAB Version:    FZ7RG.02.02.00
Laminator Version:    
Laminator MAB Version:    
ZMotif Version:    14.3
Cards Printed:    11
 
Memory
 
Available RAM:    380928
Available Flash:    0
 
Ribbon
 
Type:    71
Description:    BLACK
Initial Size:    5002
Panels Remaining:    -1
 
Status
 
Printer State:    idle
Alarms:    0x00000000
Error Code:    0
 
Job Statistics
 
Jobs Receiving or Pending:    0
Jobs in Progress:    0
Jobs Done OK:    0
Jobs with Error:    7
Jobs Cancelled:    0
Total Jobs:    7

 

So, how can I resolve, or at least diagnose the problem? In the printer information above, there is a mention of 7 "Jobs with Error." Is there a log file somewhere that I can see just what the errors are?

7 comments

0
Avatar
Ian Cummings
Moderator
Comment actions Permalink

Sounds like classic "bad USB printer installation" problem.  Use the DriverWizard.exe to remove the driver, reboot for good measure, run Driverwizard, turn on/connect printer, and in the DriverWizard make sure it prompts you if you want to install the printer it just detected -- select and continue until the end.

0
Avatar
Legacy Poster
Comment actions Permalink

OK, I ran the DriverWizard exe to uninstall. The uninstallation process required a reboot, which I did, then the uninstall continued and finished after I logged in again. After rebooting after the DriverWizard uninstall, I opened up Device Manager, enabled "View hidden devices" and uninstalled every Zebra and USB print driver installed (I only need to print to the ZXP for this machine, so it should be OK to nuke any other print drivers). There were still ZXP-related drivers listed. Rebooted again after that. Ran the DriverWizard to install print drivers, then attached ZXP to the USB port. Once again, the DriverWizard recognized the ZXP as soon as it was plugged in, and driver installation finished normally. Ran BarTender, opened up my card template and the print queue, hit Print..., and the jobs still disappear from the queue. I also set the ZXP up as a network printer, and I can view the HTTP console and print test cards from it, but the driver still does not work with the network setup.

0
Avatar
Legacy Poster
Comment actions Permalink

Oh, one more thing: Every attempt has been on Windows 8.1. Would this be better on a Windows 7 install?

0
Avatar
Ian Cummings
Moderator
Comment actions Permalink

Try manually selecting a different virtual USB port for the printer driver under the "Ports" tab of the printer driver.  Sometimes Windows can mess this up for some reason.  I don't see the OS version being relevant, but by all means try it on a different PC just in case this one is the trouble.

0
Avatar
Legacy Poster
Comment actions Permalink

I  have the same problem with Windows 7 64 bit. 

I was trying to encode cards for the first time. Initially I was using a zdesigner driver but Bartender warned me that this printer didn't support encoding! I loaded the latest (7.4.1) Seagull driver and that fixed that issue but now all my print jobs disappear. In fact nothing will print even with a new document with no encoding. The print jobs just disappear. I connected the zxp7 via network and there is communication since I can read all printer parameters from the web page and send a reset command which the printer responds to. I cannot print a test card. Jobs are queued according to the browser but it wont let me delete them.

Currently, the zdesigner still prints but the seagull doesn't. This doesn't help me with encoding.

I have tried reinstalling everything driver related without success. Plse help!

0
Avatar
Ian Cummings
Moderator
Comment actions Permalink

markn: I suggest you contact tech-support for your region: http://www.seagullscientific.com/support/technical-support/

0
Avatar
Legacy Poster
Comment actions Permalink

With the help of tech support: if the printer is set up with the wrong ribbon type (colour vs monochrome) the printer will process the print job but discard it without informing Windows of an error.

If you check the printer print queue (via a browser using TCP/IP) you will see the error messages listed.

Please sign in to leave a comment.