Printer Not Showing Up In Wps? Follow

0
Avatar
Legacy Poster

Not sure what happened during our installation but when I go to the Admin it's not showing the installed bartender printer to enable it. The printer is installed and I can print to it fine from BarTender 9.3 but not sure where to start troubleshooting to find out why the printer isn't showing up.

Do I need to have the drivers installed before I even install the WPS? Or do I need to restart the machine?

We aren't have any of these issues on our development server where I'm able to install a driver and it immediately shows up in the WPS admin once the installation finishes but not having any luck with our production server. Both systems mirror each other and have bartender installed.

4 comments

0
Avatar
Legacy Poster
Comment actions Permalink

Ok, I found out the issue and wondering if you folks can help me solve it.

When installing BT WPS it installs it in the c:\inetpub\wwwroot directory but we actually want this site in another location. What I noticed is that if we do move the site to say e:\sites from it's original installed location the printer's won't show up in the btadmin.aspx page but if we keep the site in the original install location along with copy it to the e:\site the printer drivers will show up but once we remove the c:\inetpub\wwwroot installed folder the printer drivers disappear.

What's within that folder that causing it to have trouble accessing the printer drivers outside of that folder? Is it permissions issues or is there a file that would need to exist in that location?
0
Avatar
Legacy Poster
Comment actions Permalink

Hello 1tufgt,

I saw that you were trying to do the same thing I am attempting to do. I discovered that in site administration page of bt-wps under Label Formats, there are fields that remember label settings in Save Label Format after Printing. After unchecking these and clearing my fields in my labels, I was able to move my inetpub folder from c: to e:.

I hope this helps.

Sincerely, Glove
0
Avatar
Legacy Poster
Comment actions Permalink

I am trying to connect a printer to the usb port on my TP-Link router TL-WR1043ND. The problem is when i go to the router usb settings, the printer option is not available.

Does anyone know it is possible to connect a printer to this router and send print job wirelessly to it?

Many thanks
0
Avatar
Domingo Rodriguez
Moderator
Comment actions Permalink

Hello 1tufgt,

Are you also trying to change the root folder in IIS for all your web-based applications, including BT-WPS? If yes, please also take a look at the below post: http://forums.iis.net/t/1149270.aspx

Also, once you manage to change BT-WPS to run under a different folder, make sure that the IIS_WEBPRINT account which BT-WPS creates during the installation has full access to the new folder and sub-folders (\Resources...) you're wishing to copy the BT-WPS files onto.

Please sign in to leave a comment.