Wps Follow

0
Avatar
Legacy Poster

Hello,

we are thinking in build a web (ASP .NET) and the labels will be printed from the client.
After follow the instructions of WPS and open the administrator web of WPS (localhost/BT-WPS) the browser says:

------------------------------

Error de servidor en la aplicación '/BT-WPS'.
--------------------------------------------------------------------------------

Error de configuración
Descripción: Error durante el procesamiento de un archivo de configuración requerido para dar servicio a esta solicitud. Revise los detalles de error específicos siguientes y modifique el archivo de configuración en consecuencia.

Mensaje de error del analizador: Error al leer la información de configuración del registro.

Error de código fuente:


Línea 31: <system.web>
Línea 32: <authentication mode="Windows"/>
Línea 33: <identity impersonate="true" userName="registry:HKLM\SOFTWARE\Seagull Scientific\WebPrint\identity\ASPNET_SETREG,userName" password="registry:HKLM\SOFTWARE\Seagull Scientific\WebPrint\identity\ASPNET_SETREG,password"/>
Línea 34: <customErrors mode="Off"/>
Línea 35: <sessionState mode="InProc" stateConnectionString="tcpip=127.0.0.1:42424" sqlConnectionString="datasource=127.0.0.1;Trusted_Connection=yes" cookieless="false" timeout="15"/>


Archivo de origen: C:\inetpub\wwwroot\BT-WPS\web.config Línea: 33

--------------------------------------------------------------------------------
Información de versión: Versión de Microsoft .NET Framework:2.0.50727.4952; Versión ASP.NET:2.0.50727.4955

------------------------------

The line 33 is the problem? What happen with it?

In web.config we have the default configuration: <identity impersonate="true" userName="registry:HKLM\SOFTWARE\Seagull Scientific\WebPrint\identity\ASPNET_SETREG,userName" password="registry:HKLM\SOFTWARE\Seagull Scientific\WebPrint\identity\ASPNET_SETREG,password"/>

Thanks!

1 comments

0
Avatar
Legacy Poster
Comment actions Permalink

Hi,

Just in case you didn't resolve this, I've had this several times including today.

Uninstall WPS, backup and remove any files you had in wwwroot, and re-install.

Important bit is to ensure IIS_WEBPRINT password meets complexity requirements of the local domain. Once we did that, it worked fine.

HTH

Please sign in to leave a comment.