SATO S84-ex does not print when Cancel Any Jobs is checked Follow

1

Use BarTender 2019 R1, with the Segul print drivers for SATO S84-ex and if I check the "Cancel any jobs previously queued to this printer" it does indeed clear the print buffer in the printer, but it does not send the new print job to the printer.  If I uncheck the "Cancel any jobs" option, then it prints just fine.    My application is a Label Applicator with an unknown quantity of labels required at the beginning of the print job, so I initiate the print job with a large quantity (1000) defined, but need to stop after say 300 lables, then print a new run of labels.....so if I understand it correctly, this should work as long as I choose the "Cancel any jobs previously queued to this printer" option.....it should cancel the remainder of the previous run, and start a new run..... correct?    Anybody have any ideas why this wouldn't work?

3 comments

0
Avatar
David Fink
Comment actions Permalink

Hi Michael,

Did you or your team find a solution to this issue? I'm experiencing a similar issue with BarTender and the Sato S84-ex.

1
Avatar
Pete Thane
Comment actions Permalink

Dont know the answer but as there have been a number of driver releases since the OP originally posted the query it could have been fixed in one of these. Have you tried printing with the latest set (2020.4 I believe it is)?

I dont know a lot about the Sato programming language and I assume a CAN command is being sent down via the driver. Looking at that I see there needs to be a 5 ms delay between sending the CAN and any new label data to be printed and so that could be the issue.

If you created a new "Cancel Job" label with the Cancel command enabled and send that down to the printer first and then your normal label without this ticked then that may get round it. You may need to use the adjust it so the Cancel command is sent with the new label only via this option from the Print screen

 

1
Avatar
Michael Drew
Comment actions Permalink

David, sorry for the delay, I had to dig up my notes to remember what I did.   Dont' use the "Cancel All Print Jobs" option, instead add a user command to the start of each print job by using the features in the printer driver:

After the printer is installed, locate it in the Windows Control Panel and right click and Choose Printing Preferences, then go to the Page Setup tab

Click the “Advanced Options” button and flip to the User Commands tab.   Then enter the escape codes shown in the screenshot below.   This MUST be done in order for the printer to clear its buffer when the next data is sent to the printer, otherwise it will continue to use the previous label until the total number of specified labels are printed, or until the print job is manually cancelled from the front of the printer.

^<ESC>A

^<ESC>*

^<ESC>Z

 

Good luck!   Hope this helps.

 

Please sign in to leave a comment.