Internet printing: print job won't print at client printer Follow

0

Hi!

I have an issue where i send a request to a server and the server sends a print job back to the client. When the client receives the job and send the job to the spooler, we get an error in the event viewer:

"The document Print Document, owned by USER, failed to print on printer. Try to print the document again, or restart the print spooler.
Data type: RAW. Size of the spool file in bytes: 51252. Number of bytes printed: 51252. Total number of pages in the document: 1. Number of pages printed: 0. Client computer: XXXX. Win32 error code returned by the print processor: 2152796175. "

Provider
      [ Name] Microsoft-Windows-PrintService
      [ Guid] {747ef6fd-e535-4d16-b510-42c90f6873a1}
   
  EventID 372
   
  Version 0
   
  Level 2
   
  Task 26
   
  Opcode 12
   
  Keywords 0x8000000000000840

I got a recommendation that i should change the data type from RAW to something else, but i have no clue if that is possible with the .Net SDK.

3 comments

0
Avatar
Xabier Clemente
Moderator
Comment actions Permalink

Hi Anders,

Welcome to the BarTender Community Forums!

One question is, is this the only time this has happened or has it occurred before? If so, how often, and does this happen always?

What I believe could be the cause of a problem like this is the Print Scheduler service not having sufficient permissions from a certain user login. The recommended information in BarTender Services and Permissions says that this service should run under a Local System account, but In these small, uncommon instances, the resolution is to have the Print Scheduler use the same elevated credentials that the integration is using as well.

Let me know if this makes a difference, thank you!

0
Avatar
Anders Ragnar
Comment actions Permalink

Hi and thanks for the warm welcome!

We started with server printing and realized we need client printing for solution. Server printing worked fine but we never managed to get client printing up and running. Not a single page has been printed successfully.

Unfortunately I was not able to solve the problem by adding admin login to the Scheduler service or any other Bartender service. I've been able to find some more error codes when enabling operational logging as well.

Log Name: Microsoft-Windows-PrintService/Operational
Source: Microsoft-Windows-PrintService
Date: 2022-01-18 18:32:27
Event ID: 824
Task Category: Executing print filters in the spooler pipeline
Level: Error
Keywords: Print Filter Pipeline
User: LOCAL SERVICE
Computer: DESKTOP
Description: A fatal error occurred while printing job "Print job name" id 5 on the print queue Microsoft Print To PDF. The print filter pipeline process was terminated. Error information: 0x8051100F.

I found some forum post saying that i should get older printer driver that supports type 3 instead of type 4. I haven't tried this, because we will over extend the license if we reinstall one more printer.

I also noticed the certificate on the download able Web print service is out of date. Is it possible to download an updated certificate somewhere?

0
Avatar
Anders Ragnar
Comment actions Permalink

So I did some research and i found some old forum posts that had exactly this problem but with other software. I had uninstall my type 4 print drivers and install type 3 print drivers.

Please sign in to leave a comment.