Skip to main content

Search

Search

GS1 Data Matrix - AI Code 240 not displaying correctly when I scan my barcode

Comments

5 comments

  • Avatar
    Dylan Tremmel

    To add a visual, this is what we should be getting:

    This is what we are getting:

    0
  • Avatar
    William Twomey

    Hello Dylan, I am a fellow user lost trying to navigate this software.  I posted yesterday trying to find a solution for why my barcodes will not encode data using ZPL, while text fields will pull the ZPL data and display fine on printed labels.  I have no answer for you, but good luck, and hopefully we can get some customer support!

    0
  • Avatar
    Peter Thane

    As AI 10 is a variable length field the system cannot tell when that ends and the next AI begins. You need to add a function 1 character (^1) into your string prior to the 240 AI and that should sort it.

    If you are hard coding in ZPL it looks like >8 is the string you need to add in to your barcode string

     

    1
  • Avatar
    Dylan Tremmel

    Thank you so much @Peter! You sent me on the right track. I needed to add the ^1 as a Data Terminator between the Batch Info Data source and the 240 AI Code Data source. 

     

    I hope this helps someone else as well!

    0
  • Avatar
    Peter Thane

    No problem. Normally if you use the Application Identifier Wizard to help you create the full code then BarTender will add in the terminators as it guides you through building the string but if you later amend or add to this then you have to add these manually which means you need to know where they apply. 

    0

Please sign in to leave a comment.