Saltar al contenido principal

Búsqueda

Búsqueda

Integration web service HTTPS?

Comentarios

7 comentarios

  • Avatar
    Jasper Wen
    Moderador

    Currently, an Integration web service request doesn't have an easy HTTPS option that just can be turned on. There is a feature request filed on it already. There is a way you could setup an web request Integration using HTTPS but it will also involve setting up our BarTender Print Portal web application. Essentially, Print Portal has HTTPS capabilities and Integration web requests can be sent through and redirect via Print Portal. For BarTender 2016 and 2019, it would involve the following:

    • Installing and setting up our BarTender Print Portal web application. It can be installed as part of the BarTender suite installer.
    • Setup the BarTender Print Portal with HTTPS in IIS - This guide should help get started with how to do it: https://blogs.msdn.microsoft.com/rakkimk/2007/05/25/iis7-how-to-configure-a-website-for-https/
    • Enable HTTPS in Print Portal under the administrative setup->security->enable authentication over HTTPS
    • Setup your web service integration in Integration Builder and deploy it like normal.
    • When you send a web request from your custom application, you want to send it to the following URL instead (replace the data around the carrot symbols with the appropriate information): https://<host name>/BarTender/API/Integration/<service name- the name of your web service integration you named and built in Integration builder>/Execute . This is a special URL that basically sends the web requests via Print Portal then directs it to the actual Web Service Integration to process and trigger printing with BarTender.

    Note, for BarTender 2021 and later, please refer to the following support article - Creating a secure web service integration in BarTender 2021 and later.

    0
  • Avatar
    Sean Haynes

    I set up an ssl cert and used these instructions.

    I get this error:

    • Error":"
      Failed to send data to integration service.. The remote server returned an error: (404) Not Found."

    ERROR: APIController IntegrationServicePassthrough

    The Passthrough is not finding the integration.

    Any ideas?

     

    Thanks

    0
  • Avatar
    Dev Ops

    Hi,

    IS this still the case, can we now use https for web integrations in v2019 ?

    0
  • Avatar
    Sean Haynes

    I never got it to work (see the error above). Support never responded to my thread.

    0
  • Avatar
    Darrell Flenniken

    Has anyone been able to get a secure (https)  web service integration to work?

    0
  • Avatar
    Bruse Tai
    Moderador

    Hi Darrell and Sean,

    Thank you for the posting. It should work on BarTender 2016 and 2019.
    (Suggest using the latest service release 2016 R9 and 2019 R10)

    Please try the following steps and test it again. 

    a. IIS setup: (Enable HTTPS)
    1. Create a certificate
    Open IIS (Internet Information Service) -> select the PC name -> click "Server Certificates"

    Click."Create Self-Signed Certificate" -> Specify a name (for example: test) -> click "OK" button

    2. Binding
    - Select the Sites (Default Web Site by default) -> Bindings -> Add -> Select "https" -> Select the SSL certificate we just created in step 1.
    - Restart the web site (stop and start)


    b. Print Portal setup:
    Open BarTender Print Portal -> Administrative Setup -> Security -> select "Enable authentication over HTTPS" -> click "OK" button.


    c. The test result:
    Create a simple web service Integration for testing. 
    URL by default: https://localhost/BarTender/API/Integration/WebServiceIntegration/Execute
    Check the result in Integration Builder.

    0
  • Avatar
    Roscoe Bishop

    Hi there, we are on Bartender 2016 R8 and trying to use the "special URL that basically sends the web requests via Print Portal then directs it to the actual Web Service Integration to process and trigger printing with BarTender." We get an error message that says:

    Unable to run action 'Print Document' because the copies per serial number value of '%PrintQTY%' is invalid. Please specify a valid number and re-run the action.

    In our Print Option Overrides, we have Copies selected with the %PrintQTY% variable specified. When we do not use the special URL and go straight to/through the web service, this works as expected and prints the number of copies as specified by the value. 

    Does the "web requests via Print Portal then directs it to the actual Web Service Integration" solution support a variable for Copies? 

    0

Iniciar sesión para dejar un comentario.