Database already exists. Choose a different database name. Seguir

0
Avatar
Patrick van der Linde

We have just updated our Bartender software to BarTender Enterprise Automation 2016. When I run Bartender Administration Console and try to connect to the already existing Bartender Database, it gives me the error "Database systemDB already exists. Choose a different database name."

Did anyone encounter this? And more important, does anyone have a solution for this?

Kind regards,
Patrick

4 comentarios

0
Avatar
Jasper Wen
Moderador
Acciones de comentarios Permalink

This is a known issue and bug that has been reported with R3 2016 connecting to an existing BarTender System Database.

As a workaround, you can use the silent installation and the command line to connect to the BarTender System Database - See our BarTender help here.

Here are some examples of commands to connect to existing system database. The first example runs the BarTender system database wizard without user dialog and generates a log file. Also sets up a connection to an already existing BarTender system database. It will create a new BarTender system database on the SQL server if one does not already exists. The 2nd example is similar but uses SQL Server authentication instead. Note, when you use the /Silent parameter to run the database connection setup so Windows do show, you have to specify a location to generate a log file. Also, make sure to replace the parameters with the appropriate SQL Server name, database name, username, and password. If you are upgrading your system database, you will also need the /upgrade parameter.

  1. SystemDatabaseWizard.exe /Silent /Log=C:\log /Type=Connect /Server=SQLServername /Authentication=Windows /Database=BarTender
  2. SystemDatabaseWizard.exe /Silent /Log=C:\log /Type=Connect /Server=SQLServername /Authentication=SQL /UserName=JohnDoe /Password=test /Database=BarTender
0
Avatar
Patrick van der Linde
Acciones de comentarios Permalink

Thanks, Jasper, this got me further. Unfortunately I didn't succeed in connecting to the database yet.

The log told me I had insufficient authorizations for the database (stupid of me in the first place), so I added the bartender account to the database security.
After this I ran the command line again. In the log it stated it's making a backup of the database (since the db version is older than the current version). Then, after an hour, the log says it couldn't back-up the database within a reasonable time and disconnects.

I checked if there is a parameter to disable the back-up, but that doesn't seem to be present.

Can you offer me more help with this?

0
Avatar
Mike Schur
Acciones de comentarios Permalink

Dear Patrick,

i had a similiar issue to upgrade our Bartender database from version 1.40 to 1.60 and got a not working workaround description for that from our local reseller support which includes the same commands from the link above.

Yesterday i've tested the second example from Jespers comment and then the upgrade finished completely!

Is your bartender account a domain- or sql account? If it is a windows account you can use the option /Authentication=<Domain>\<Account> & /Password=<Account password> !

And check therefore that you have enough free disk space on drive C because the database backup will be stored on "%ProgramData%\Seagull\System\Database\Backup"!!!

I'll hope this informations will help you. I'll forward my findings to my local reseller support for that database upgrade issue.

Greetings

Mike Schur

0
Avatar
Patrick van der Linde
Acciones de comentarios Permalink

Thanks Mike, this worked! Just needed to change your /Authentication= to /UserName=, but then it worked like a charm.

Now I'm running into another issue with the Bartender software, but I'll post a new post on that, since it's completely different.

Iniciar sesión para dejar un comentario.