Print job with multiple labels -> every single lable gets sent to the printer as a single print job Seguir

0

We are experiencing a weird issue with bartender:
When we start a print job of say 50 labels - our printer receives 50 single print jobs for 1 label.

This is annoying as in case of an error we have to manually delete every single label.

Can anyone help?

21 comentarios

0
Avatar
Xabier Clemente
Moderador
Acciones de comentarios Permalink

Hi Tobias!

Thank you for reaching us via the Community Forums!

In order to properly troubleshoot this issue, could you tell us what print method are you using? Are you printing directly through BarTender Designer, or are you using an Integration, Print Portal, etc?

If you have noted this unwanted behavior when printing with BarTender Designer, this issue could be due to a misconfiguration in the print screen. If you navigate to BarTender's "File > Print..." tab, please make sure you have selected the 50 records in the "Queried Records..." field instead of te Copies field:



If the 50 is in the Copies field, then we have our culprit, and it should be as easy as changing this number to "1" and then selecting the number of records in the bottom Queried records field.

I hope this helps!

0
Avatar
Peter Thane
Acciones de comentarios Permalink

You may want to look at some of these settings:

If using sequential numbers you would need to use an in built device font (Zebra Trimumvirate for example) so that the command is sent down with the instructions for the printer to print the label X times increasing the number by Y each print. 

 

 

0
Avatar
Tobias Gessner
Acciones de comentarios Permalink

Hi,

no we need to print the same label / record 50 times - our printer gets 50 print jobs of single labels.

This happens when printing with the designer as well as using the print station.

0
Avatar
Tobias Gessner
Acciones de comentarios Permalink

Peter, thanks for your input.

Our printing specifications look like this:

But we did not change those in the past.

Apparently this issue happens since we followed the instructions you kindly provided on this thread:

https://support.seagullscientific.com/hc/en-us/community/posts/4415220885783-Record-selection-Different-angles-to-print-the-labels-

With old files this does not happen.

maybe this helps?

0
Avatar
Peter Thane
Acciones de comentarios Permalink

You could try enabling the template caching option and see what that does.

0
Avatar
Tobias Gessner
Acciones de comentarios Permalink

Do you mean just activate this checkbox?
This does not solve the issue

 

0
Avatar
Tobias Gessner
Acciones de comentarios Permalink

Is there any other possible solution for this? Thank you!

0
Avatar
Peter Thane
Acciones de comentarios Permalink

It is likely to be the fonts you are using. If you use the internal printer fonts rather than True Types then you can probably get round this

0
Avatar
Tobias Gessner
Acciones de comentarios Permalink

Hi - also with the internal fonts this problem remains - any other idea? this only happened with the conditional print stated above

0
Avatar
Peter Thane
Acciones de comentarios Permalink

It must be the conditional printing that is preventing this then.

To clear down the printer in error you will probably need to either reboot it or send a ~JR reset command to it. 

I haven't got a printer to test with but I believe the commands will be something like this, if you create a new "reset" label and add these on (Document Properties>Page Setup>Advanced Options>User Commands)

 

 

0
Avatar
Tobias Gessner
Acciones de comentarios Permalink

Thanks - will try this.

However will this prevent us from starting multiple print jobs in a row in advance?

When we send 4 different print jobs containing 100 labels each to the printer will all of them still be processed?

also, even if the printer is restarted manually - starting a new single print job containing 100 labels - we still get 100 print jobs of 1 label.

0
Avatar
Tobias Gessner
Acciones de comentarios Permalink

Your solution causes a syntax error on our printer (CAB SQUIX)

0
Avatar
Peter Thane
Acciones de comentarios Permalink

Sorry for some reason I thought you were using a Zebra printer and that is a ZPL command.

You need to send an ESC t command to the printer I believe to clear the current job and all others in the buffer.

 

0
Avatar
Tobias Gessner
Acciones de comentarios Permalink

 

 

This still does not solve the issue

0
Avatar
Peter Thane
Acciones de comentarios Permalink

You have missed the t off the end. 

0
Avatar
Tobias Gessner
Acciones de comentarios Permalink

Sorry, which command exactly should we use?

Heres all the options I am given

 

0
Avatar
Peter Thane
Acciones de comentarios Permalink

No extra command, just a lower case T after the <ESC>

so 

~<ESC>t

0
Avatar
Tobias Gessner
Acciones de comentarios Permalink

Still the same issue... any other ideas?

0
Avatar
Peter Thane
Acciones de comentarios Permalink

Try removing the Tilda and just send the ESCAPE t ( <ESC>t ) command.

0
Avatar
Tobias Gessner
Acciones de comentarios Permalink

doing so causes a syntax error

0
Avatar
Peter Thane
Acciones de comentarios Permalink

Sorry I haven't got a printer to test with and so going from memory and the old CAB programming manual and so it could be the syntax is wrong.

If you put the printer into HEXDUMP mode you could then from the driver use the Printer Properties>Tools>Actions and Cancel All Jobs command then that should send the full command down showing the syntax required and so you would need to replicate that.

 

 

Iniciar sesión para dejar un comentario.