Bartender 2016 Permission Denied S’abonner

0
Avatar
Rick Thompson

 I just installed BT 2016 Enterprise and selected the security option from the Admin Console (Select System DB). I then closed the Admin Console and now can no longer run any BarTender application. A dialog shows indicating "Permission Denied". I'm running as an administrator, I've uninstalled BarTender, wiped out the database completely, cleaned up portions of the registry, and then reinstalled and I still get the same error.

I've seen the "bartender-system-security.pdf" document but see now way to get back to the setting except via the Admin Console, which also won't run because of the permission issue. This server was a fresh VM before I did the first installation - everything was going fine until I select the security option in System DB and after that I ran into problems.

Any recommends?

 

Thanks,

Rick

 

6 commentaires

0
Avatar
Flavia Medici
Modérateur Commentaire officiel

Hello Rick

 

This is an issue that tech support is going to want to handle with you directly.

I have created a ticket for you on this, and we will be reaching out to you shortly.

0
Avatar
Christoph Wuetschner

i just got this error yesterday,

i'm testing the new version of BarTender (Testversion) cause we want to use the newer version.

But let me say so... why is it so difficult to set up ???

And why can things like this happen more than one year after it happend to Rick Thompson?

The old version is of course easier to handle but we have to migrate to a newer BarTender server.

If i can read Ricks text and the answer correctly, it is not possible to remove all BarTender, reinstall and try to make my setup again?

Then please help me with my problem

Thank you

 

0
Avatar
Cliff Gwilliam

I've downloaded the trial version of 2019 to do some design and integration testing for a new ERP implementation happening in July (i did the initial development in a trial version of 2016). I did manage to run Bartender and Integration Builder last week, but I tried to go back in yesterday and I'm getting the same error as reported above.

Any ideas as to how I can proceed?

Thanks

 

0
Avatar
Richard Lorandin

Hi, same thing here : The security policy doesn't allow the user to acces to  the Bartender Administration system.

When we check on the log, we can read about the MSSQL process :

Login failed for user 'XXX'. Reason: Failed to open the explicitly specified database 'Datastore'. [CLIENT: <local machine>]

 

Any idea ? 

 

0
Avatar
Darrell Flenniken

I setup BT 2019 running in free mode to create a Proof of concept and everything was working until today when I got the same error trying to start any BT Application.

Now dead in the water.

 

What's the resolution to this problem?

0
Avatar
Jasper Wen
Modérateur

For those here using BarTender 2019 and getting "Error #2622 - BarTender's security policy does not allow the specified user to perform this action." intermittently when trying to open BarTender, this is a known issue we are looking to address in the next service release. Generally, you can workaround the issue by restarting the BarTender System Service from the Windows services list.

Veuillez vous connecter pour laisser un commentaire.