Problem / Error when reading unicode data/fonts from CSV file S’abonner

0
Avatar
Nicholas Zieleniewski

We have a standard Windows 10 install and are running the BarTender 2021 30 days trial.

Printer is EPSON 6000Ae.

I am (trying) using the BarTender Integration to read from a csv that is dropped into a folder, flow the data into a template and print. This has proved easy enough and I have it working.

The problem is reading non-english characters from the utf8 csv files. In Integration, in the Integration tab/selection on the left I can take a sample of the EventData. On selecting my file the small amount of Korean text I have entered under product_name does not show correctly, and this is fed to the printer and prints the random characters that are seen on the screen.

On the Actions part, under 'Transform Test To Record Set', when using the Database Connection Setup, the text is read from the same file and displays correctly on the screen.

Also, copy and pasting the Korean straight from the csv file into the BarTender Designer application, the text (and I am ensuring it is text on the screen, not a picture) prints correctly straight from the app. The csv also prints correctly when just printing straight from wordpad / libreoffice / excel.

So, I am convinced the issue is BarTender reading the data at the 'Input Data' part. I just cannot find a setting to change it.

(Please ignore the fact the two integration files are different, I restarted again to work through from the start but the issue was the same. The issue is the same on both).

 

 

 

 

 

2 commentaires

0
Avatar
Pete Thane
Actions pour les commentaires Permalien

Not sure but have you tried changing the input encoding to Korean? 

0
Avatar
Nicholas Zieleniewski
Actions pour les commentaires Permalien

Hello Pete, thank you for your reply.

Thankfully I found out how to do it. It wasn't the above.

I had to ensure the utf8 csv was saved with BOM.  I guess this forces (encourages) BarTender to ensure it's pulling the data using the right encoding. It's just strange it worked at the 'transfer text to record set' part already, but not the input data part.

Hopefully this helps someone else with a similar issue.

Thank you again.

Nick

 

Vous devez vous connecter pour laisser un commentaire.