Tcpip Trigger With Http Post S’abonner

0
Avatar
Legacy Poster

Hello,

I'm trying to use TCPIP Trigger from SAP because I don't like to use filesystem and IDoc files. I directly try to send the IDocs as XML-IDoc. Now the problem: SAP (like most other application which can send XML and can consume WebServices) is using HTTP as transport protocol, so if I choose Bartender to write the input to file it looks like:

POST / HTTP/1.0
content-type: text/xml; charset=utf-8
content-length: 801
user-agent: SAP Web Application Server (1.0;701)
host: 10.xx.xx.xx:8000
accept-encoding: gzip
sap-language: D

<?xml version="1.0" encoding="UTF-8"?><IDOCNAME>....

Of course I need to do a XSL transformation from XML-IDoc to Bartender XML Script, but the problem are the 8 lines before XML begins which I need to remove before I can execute the transformation. Is it possible in Bartender as a first step to remove the lines (maybe with Windows batch file) and as second step perform the transformation?
For future I think it would be nice to implement HTTP handling into TCPIP trigger also because you get the content-length and know when the transfer is finished.

Regards
Markus

2 commentaires

0
Avatar
Legacy Poster
Actions pour les commentaires Permalien

Seems like it's working with another transformation step with "Search and Replace". Now I need to test the generated Bartender XML. What I don't understand is that if I add a "Save in file" step after the "Search and Replace" transformation, it writes the input like before transformation and not after.
If entering something like "HTTP/1.1 200 OK«CR»«LF»Content-Length: 0«CR»«LF»Server: Seagull/1.0«CR»«LF»«CR»«LF»" in the messages tab in advanced connection options SAP thinks it got a valid HTTP 200 response and IDoc outbound status gets green. I had a look at the SAP AII example which helped me a lot to identify these "workarounds" for using normal HTTP traffic.
0
Avatar
Gene Henson
Modérateur
Actions pour les commentaires Permalien

Hello,

When you are using the Save to File command, you want to make sure that you select “Filtered Trigger Contents” as the source. This will ensure that Commander uses the post transform file.

You can access this option by following these steps:

[list=1]
[*]Open the Commander Task List
[*]Double click on the task to open its options
[*]Go to the Commands Tab
[*]Click the button labeled “…” for your Save To File command
[*]Select “Filtered Trigger Contents” for the source
[/list]
Does that work for you?

Vous devez vous connecter pour laisser un commentaire.