Trigger File Error Printing A Label With The %end% S’abonner

0
Avatar
Legacy Poster

I am having trouble with our upgrade from version 9.4 SR3  to version 10.1 SR4

 

This is the sintax we are trying to use to get the lables:

 

%BTW% /f="\\usphos-bcprn1\Apps\bartender\Avante labels\BXTmplt22.btw" /d="%Trigger File Name%" /PRN="pick_pack17" /p  /dd
%END%
"10620420","SB:1006-12/24D-613-LBSM","Electric Strike Body Only","24V DC CONT/INTER","STD/FAIL-SECURE","DARK BRONZE","74009004121","100610420","12VDC/0.45 Amp","24VDC/0.25 Amp","1","1,500 LBS","70 Ft-Lbs","250,000 Cycles","6,021,038 6,595,564","www.yourwebsite.com","DONT LINK","\\usphos-bcprn1\Apps\bartender\Avante labels\Images\Image_Label.jpg"
 
When I send this, 2 labels are printed, first one with the %END% and a barcode (%END%) and then my label with the information above.
 
This does not happen on the previous version 9.4 SR3
 
We are using the following TXT file as the DataSource TXT file
 
"PartNo","ProductDesc","LabelDescription2","LabelDescription3","LabelDescription4","LabelDescription5","UPC_Barcode","CustomerXRef","Voltage","Field10","Voltage_2","Static","Dynamic","Endurance","Patents","WebSite","Notes","ImagePath"
 
To assign the fields.
 
I have tried adding the /R=3 but doesn't make a difference, and sometimes it doesn't print anything.
 
If I take the %END% off, it will print only the label we need. However, Seagull Support is telling me that we need to add the $END$
 
 

6 commentaires

0
Avatar
Ian Cummings
Modérateur
Actions pour les commentaires Permalien

Both versions of BarTender would require you to have the /R=3 command option specified as this tells BarTender that the record data starts on row 3 of the trigger file.  You probably need to check the setup of the actual document in terms of record selection which should be set to "All records".  Be sure to save the document file once you make any changes and restart detection in Commander to force the changed document to reload.

0
Avatar
Legacy Poster
Actions pour les commentaires Permalien

Thanks Ian, 

 

Tried your recommendation,

 

1. stopped and restarted commander

2. Checked the document record selection, it was on ALL RECORDS

3. Added the /R=3

 

Result: No print out.

 

4. Removed the /R=3  and the label printed.

 

What I found out after posting this, was that on our v 9.4, the person who created these templates, had the Quantity to print taken from a data field on the record data. Once I did this on 10.1 it printed OK withouth the %END%

 

I don't understand why the /R=3 doesn't work for my templates, right now I don't seem to need it.

 

Would be nice that Seagull published a better manual on the Syntax for the trigger file explaining better what each command does, I tried the examples and the current manual and seems to be a lot of trial and error.

0
Avatar
Ian Cummings
Modérateur
Actions pour les commentaires Permalien

Please leave the /R=3 in as this is what you are supposed to have.  The cause of the problem is something else.

 

Could it be that in the document you've set there to be a header for the first row of the text file.  If so disable that in the document file, save, and try again.

 

The Commander trouble-shooter should help you in future: http://forums.seagullscientific.com/index.php?/topic/55-commander-troubleshooting/

0
Avatar
Legacy Poster
Actions pour les commentaires Permalien

Ian 

 

Thanks for the document!

 

Just to clarify, the Document you are referring to is the Datasource? 

 

I have the datasource as a .txt file and in fact, on the DATABASE CONNECTION SET UP, on the Options tab, I have checked the "First Record Has Field Names"

 

Maybe I am not looking on the right place?  Can you please be more specific on which document is it and where to disable this setting of the header for the first row of the text file?

 

thanks for your patience, I am not as experienced in Bartender as you are.

0
Avatar
Legacy Poster
Actions pour les commentaires Permalien

Ian,

 

I unchecked the "First Record Has Field Names" on the DATABASE CONNECTION SET UP, on the Options tab as a test and it worked. it printed with the /R=3.

 

Thanks!

0
Avatar
Ian Cummings
Modérateur
Actions pour les commentaires Permalien

Document as in BarTender document file, but it seems like you already figured it out. :)

Vous devez vous connecter pour laisser un commentaire.