Sap Glm With Zebra Printer: Seagull Drivers S’abonner

0
Avatar
Legacy Poster

Hi All,

 

We have integration with SAP GLM- we use WWI functionality meaning windows word which will create a final label based on xml generated per print job. The input is then sent to ZEBRA printer to print. We have ZEBRA 170xi4 (300 dpi)  

Zebra 170xiIII Plus (300 dpi) being used with Seagull 64 bit drivers. 

 

The seaguall drivers are upgraded from 32 bit to 64 bit and word from 2003 to 2010. 

Issue: When we send more than 1 copy to printer for e.g. 4 or 100 then its expected that printer will produce those number of copies and display 1 of 100, 2 of 100 and so..on the printer display screen. But this is not happening. The printer shows 1 of 1 always and repeats this 100 times, till we get all prints. Meaning instead of making 100 copies from 1, each time its taking 1 as a copy. This is causing printer pause, and counter display on printer is also incorrect.

When we manually selected the 'Un-collated' option in word everything worked fine. But we can not do the manually and it has to happen automatically when every print goes from SAP to the printer. This was working before with collated option but it was word 2003 and 32 bit drivers.

 

I cant find any option on ZEBRA something like mopier mode off. I suspect the printer drivers are not interpreting the inputs properly. PFB expamples

with collate option:

^XA
^FO32,69
^XGR:SSGFX000.GRF,1,1^FS
^PQ1,0,1,Y
^XZ
 
Where PQ1,0,1 is repeated with same information 100 times. But when we tried with un collated below is the result.
 
^FO32,69
^XGR:SSGFX000.GRF,1,1^FS
^PQ4,0,4,Y
^XZ
 
PQ4,0,4 shows number of copies and data will not be sent 4 times to the printer- its only one time but repeated 4 times.
 
Any suggestion?
 
Regards,
Sachin
 

4 commentaires

0
Avatar
Ian Cummings
Modérateur
Actions pour les commentaires Permalien

The copies quantity value on the printer reflects the amount specified in the issue (^PQ) command.  You have 100 of these for one copy thus the result you see.

 

Is the entire print run of 100 labels supposed to be absolutely identical?  If yes then the problem lies in Word.  Try the same using BarTender and our driver and you'll see a single issue command for 100 labels.  In fact, do this with Windows Notepad, collate disabled, and you'll get the same 100 label issue command.

0
Avatar
Legacy Poster
Actions pour les commentaires Permalien

Thanks,

 

Your are right, its the word issue but can this be solved alone with the upgraded or any other driver version. This was working before with Segull drivers 32 bit, but now OS is on 64 bit and new seagull drivers with 64 bit is not considering this.

 

Can we have any solution alone on driver?

 

Regards,
Sachin

0
Avatar
Ian Cummings
Modérateur
Actions pour les commentaires Permalien

This has been reported elsewhere and diagnosed by development, but unfortunately for you this is a Word 2010 issue, you'll need to chase Microsoft.  Might I suggest you consider using BarTender instead for the generation of highly optimized printer code.

0
Avatar
Legacy Poster
Actions pour les commentaires Permalien

Hello Sachin, Did you solve this issue in your WWI server. We are also having this issue after Server OS & WWI SP upgrade. Kindly advice if you have found a resolution for this issue. Thanks.

Vous devez vous connecter pour laisser un commentaire.