Cannot Load Seagull.bartender.print.dll S’abonner

0
Avatar
Legacy Poster

Good day !
I am using Bartender Enterprise v9.2 and Visual Studio 2010. The problem is when i create an instance of Engine, the error occurs.
The message is "Could not load file or assembly 'Seagull.BarTender.Print, Version=9.20.1.0, Culture=neutral, PublicKeyToken=null' or one of its dependencies. An attempt was made to load a program with an incorrect format.?"
Please help me how to solve this problem.
Best regard !

34 commentaires

0
Avatar
Legacy Poster
Actions pour les commentaires Permalien

Thanks Domingo,

 I think we are going to go with option 3. Update another piece of software on that Windows 2000 box, so then we can update the OS to something more current and upgrade our software to 4.0.

At that time I can revisit bartender.

 

Thanks again.

0
Avatar
Legacy Poster
Actions pour les commentaires Permalien

Hello ilthoss,

 

There are plans to upgrade the SDK to 4.0 and also plans to make a 64bit SDK (once BarTender is available as 64bit application).

 

We don't want to make the move to a higher SDK too soon, because otherwise there would be customers still wishing (or needing) to use .NET Framework 2.0, 3.0 and 3.5 which wouldn't able to make use of our SDKs.

The .NET 2.0 Framework was released in 2007!!!  I think it is time to upgrade to at least .NET SDK 4.0 even though there is a stable release of 4.5.2 version available. If customers need older versions of your .dlls then you need to provide it to them.  Give your customers the ability to choose which framework they want to target.  

 

I was having this error message come up and I simple added this line to my app.config file to fix it: 

 

<startup useLegacyV2RuntimeActivationPolicy="true"> 
   <supportedRuntime version="v4.0" sku=".NETFramework,Version=v4.0" />
</startup>
0
Avatar
Ian Cummings
Modérateur
Actions pour les commentaires Permalien

jaredbaszier: Yes we understand, and yes we are working on getting our support updated in this respect.

0
Avatar
Ian Cummings
Modérateur
Actions pour les commentaires Permalien

Check out BarTender 2016, now supporting x64 and .NET framework 4.0: http://www.seagullscientific.com/downloads/label-software/barcode-label-printing-software-download/

Vous devez vous connecter pour laisser un commentaire.