Deploy .net Application S’abonner

0
Avatar
Legacy Poster

I have created a .net application for printing labels on Zebra printers. is the Dll from the SDK the only thing needed in the deploy?
Or should bartender be installed on every computer?
i am working with the enterprise edition (3 Barcode printers)
I am using a license server.

Regards

Ludo

13 commentaires

0
Avatar
Gene Henson
Actions pour les commentaires Permalien

Assuming that you are deploying this as a Windows application to multiple computers, you will need to install BarTender on each of the computers that will be using your application. If it is a web application, then BarTender only needs to be installed on the web server that will actually be generating the print jobs.

In any case, the BarTender application does need to installed because the SDK just controls BarTender, it doesn't actually generate the print jobs.

Does that answer your question?
0
Avatar
Legacy Poster
Actions pour les commentaires Permalien

[quote name='Gene H - Seagull Support' timestamp='1311799478' post='293']
Assuming that you are deploying this as a Windows application to multiple computers, you will need to install BarTender on each of the computers that will be using your application. If it is a web application, then BarTender only needs to be installed on the web server that will actually be generating the print jobs.

In any case, the BarTender application does need to installed because the SDK just controls BarTender, it doesn't actually generate the print jobs.

Does that answer your question?
[/quote]

Yes thank you.
0
Avatar
Legacy Poster
Actions pour les commentaires Permalien

I would like to add on some question.

[s]If I develop the application by using Full BarTender Suite 9.4 SR3. Then the computer which will using the application is using BarTender Only 9.4 SR3 and another computer with BarTender Ultralite 8.01.
But they hitting to "Could not load file or assembly 'Interop.BarTender, Version=9.40.3.1, Culture=Neutral, PublickKeyToken=109ff779a1b4cbc7' or one of its dependencies. The system cannot find the file specified."

I would like to know what did I miss out when I building my application exe?
Or I must install the same BarTender application with the develop PC?[/s]

I have found out the problem is due to the installer problem.

After fixing it, I have tested on BarTender Only 9.4 SR3 is working but when testing on BarTender Ultralite 8.01 will show me the message below:

"The BarTender engine counld not be started. Possible reasons are:

1) BarTender is not properly installed.
2) BarTender is not properly registered on the computer (e.g bartend.exe /register).
3) There are too many process instances of BarTender running. Stop a few bartend.exe instances and try again. Also see SDK Engine.Start method documentation for information about how to allow more BarTender processes to run on your computer by increasing your "non-interactive" shared desktop heap."

The pc which installed BarTender Ultralite 8.01 is windows XP. The installer been created is targeting x86.

Is it due to I using the 9.4 SDK building the exe therefore the client pc which installing the BarTender 8.01 can't support?

Is there any SDK for BarTender 8.01?


Thanks.
0
Avatar
Shotaro Ito
Actions pour les commentaires Permalien

[quote]Is there any SDK for BarTender 8.01?[/quote]
.NET SDK is available from BarTender 9.01, so at the time of 8.01 only availble SDK is ActiveX COM Automation.
BarTender UltraLite doesn't have capabilty to run from Automation / SDK, so you need to install BarTender Automation to the client PC.
0
Avatar
Legacy Poster
Actions pour les commentaires Permalien

[quote name='Shotaro I -Seagull Support' timestamp='1317606094' post='737']
.NET SDK is available from BarTender 9.01, so at the time of 8.01 only availble SDK is ActiveX COM Automation.
BarTender UltraLite doesn't have capabilty to run from Automation / SDK, so you need to install BarTender Automation to the client PC.
[/quote]

Thanks for the reply.

Is the BarTender Automation included to BarTender 9.4 (not the full BarTender)? Or it will be another separate installer?

From this case is it means that the application which build by using SDK BarTender 9.01 onwards, by only installing BarTender UltraLite the application will not run successful?

Thanks again.
0
Avatar
Shotaro Ito
Actions pour les commentaires Permalien

.NET SDK application won't run on BarTender UltraLite edition.
BarTender application is included in BarTender. It will be installed by default install, or custom install with "BarTender" enabled.
To run .NET SDK or ActiveX automation, you need to purchase BarTender Automation License and Activate BarTender as Automation Edition.
(You can try Automation functionality (such as .net SDK/ActiveX) within 30-day trial, which can be downloaded from [url="http://www.seagullscientific.com/aspx/free-bar-code-label-printing-software-download.aspx"]here[/url])
Hope that helps.
0
Avatar
Legacy Poster
Actions pour les commentaires Permalien

[quote name='Shotaro I -Seagull Support' timestamp='1317618652' post='741']
.NET SDK application won't run on BarTender UltraLite edition.
BarTender application is included in BarTender. It will be installed by default install, or custom install with "BarTender" enabled.
To run .NET SDK or ActiveX automation, you need to purchase BarTender Automation License and Activate BarTender as Automation Edition.
(You can try Automation functionality (such as .net SDK/ActiveX) within 30-day trial, which can be downloaded from [url="http://www.seagullscientific.com/aspx/free-bar-code-label-printing-software-download.aspx"]here[/url])
Hope that helps.
[/quote]


Is it means that all PC which installing the software which included BarTender .Net SDK need to install the BarTender with Automation License? Or with normal license will do? (as from the link you provided, have BarTender Only and Full BarTender Suite. Is it just activate any of them with the Automation License will do?)

Thanks.
0
Avatar
Shotaro Ito
Actions pour les commentaires Permalien

Sorry for late reply - Yes you need to install BarTender with Automation License for each PC which runs BarTender .net SDK App.
(I'm not sure what "Normal License" you meant, however Professional / Basic / UltraLite Edition doesn't support .net SDK application.)
For Automation Licensing, see [url="http://www.seagullscientific.com/aspx/bar-code-label-software-features.aspx"]Product detail[/url] or this [url="http://s3.amazonaws.com/SeagullBarTender/ftp/WhitePapers/WhitePaper_LicensingForBarTendersAutomationEditions_English.pdf"]White Paper[/url].

For trial, Download full BarTender suite.
To install BarTender only to Use BarTender Print SDK app, select Custom install and Select "BarTender"(Including "System Database").
This setting installs required DLL for .net SDK app, along with BarTender application.

You don't need to setup BarTender system database (SQL Server log database) via System Database setup wizard.

Hope that helps!
0
Avatar
Legacy Poster
Actions pour les commentaires Permalien

[quote name='Shotaro I -Seagull Support' timestamp='1317700342' post='748']
Sorry for late reply - Yes you need to install BarTender with Automation License for each PC which runs BarTender .net SDK App.
(I'm not sure what "Normal License" you meant, however Professional / Basic / UltraLite Edition doesn't support .net SDK application.)
For Automation Licensing, see [url="http://www.seagullscientific.com/aspx/bar-code-label-software-features.aspx"]Product detail[/url] or this [url="http://s3.amazonaws.com/SeagullBarTender/ftp/WhitePapers/WhitePaper_LicensingForBarTendersAutomationEditions_English.pdf"]White Paper[/url].

For trial, Download full BarTender suite.
To install BarTender only to Use BarTender Print SDK app, select Custom install and Select "BarTender"(Including "System Database").
This setting installs required DLL for .net SDK app, along with BarTender application.

You don't need to setup BarTender system database (SQL Server log database) via System Database setup wizard.

Hope that helps!
[/quote]


Thanks for the detail explanation.
I have just try to install BarTender only, I have select Custom install but what I can found is "BarTender" and "Tutorial". After expending the "BarTender" the sub-title are "Components", "Fonts" and "Samples". I did not see any "BarTender"(Including "System Database") (The installer I downloaded is BT94_SR3_2781_Trial_EnglishOnly.exe).

Do I miss out any thing or misunderstand?

Thanks again.
0
Avatar
Shotaro Ito
Actions pour les commentaires Permalien

Dear Alien,
Please download "Full BarTender Suite", instead of BarTender only.
Thanks!
0
Avatar
Legacy Poster
Actions pour les commentaires Permalien

[quote name='Shotaro I -Seagull Support' timestamp='1317715660' post='751']
Dear Alien,
Please download "Full BarTender Suite", instead of BarTender only.
Thanks!
[/quote]


Thank you for all the support and help.

Seems that only Full BarTender Suite can meet my requirement.

Thanks again.
0
Avatar
Legacy Poster
Actions pour les commentaires Permalien

ASP.NET applications need to run on a web server using IIS.
These applications also use the .NET Framework...and of course ASP.NET.

I have never tried to run an ASP.NET application on a Linux web server because they require IIS (a windows feature), the .NET Framework (the Windows framework), and ASP.NET (also a Windows component).

You might not be able to run these applications on a Linux box even if you are using MONO because you need IIS.
0
Avatar
Ian Cummings
Modérateur
Actions pour les commentaires Permalien

Check out BarTender 2016, now supporting x64 and .NET framework 4.0: http://www.seagullscientific.com/downloads/label-software/barcode-label-printing-software-download/

Vous devez vous connecter pour laisser un commentaire.