Suppressing Text Object With White Text On Black Background S’abonner

0
Avatar
Legacy Poster

Running Bartender 10.1 SR3

 

I am trying to create a label that has standard black text if the product part number meets certain criteria, and the font needs to be white on black background if certain other criteria are met.

 

Sounds simple.

I created two text objects, one with standard text suppressed if certain criteria are met - this works OK,

the second text object if formatted with white text on black background and this is supposed to be suppressed if certain other criteria are met.

 

The problem is that the second text object only suppresses the white text and not the black background?!

This means that the black background prints regardless of the criteria.

 

Can anyone offer an help on this?

4 commentaires

0
Avatar
Legacy Poster
Actions pour les commentaires Permalien

Do you have BarTender Automation or higher? If so, you can run an onProcess VB script to change the PrintVisibility of the object, rather than just suppress the data source.

 

... Except now that thinking about it you could just use that to programatically change the text from black to white anyway.

0
Avatar
Shotaro Ito
Modérateur
Actions pour les commentaires Permalien

There's "White on Black" button on toolbar to make white on black text.

If that works fine with Print Preview but not actual printout and you use Seagull printer driver,

On Print dialog...

Object Print Method tab,  Box to "Raster Graphics"

Performance tab, disable all optimizations.

0
Avatar
Legacy Poster
Actions pour les commentaires Permalien

Thanks nRyder,

Yes, I am using the Automation edition.

I was hoping to use the Suppress option because I am not sure how to write the onProcess VB Script - guess I will have to do a bit of research.

 

Thanks Shotaro, I will give this a try and update the post.

0
Avatar
Legacy Poster
Actions pour les commentaires Permalien

There's "White on Black" button on toolbar to make white on black text.

If that works fine with Print Preview but not actual printout and you use Seagull printer driver,

On Print dialog...

Object Print Method tab,  Box to "Raster Graphics"

Performance tab, disable all optimizations.

This worked a treat, thanks!

Vous devez vous connecter pour laisser un commentaire.