Gs1-128 Udi - Bartender Adds An Extra Check Digit And Discards The Leading '0' S’abonner

0
Avatar
Legacy Poster

Hi,

 

I am trying to change the current 1D barcode to GS1-128. However, I am having a few issues and they are as follows:

 

- I have updated the data source (excel file) and added a leading zero to my GTIN 13 to make it 14 characters. However, Bartender does not detect that leading '0' and ends up adding a check digit at the end.

- Even when I check the data in FILE - DATABASE CONNECTION - BROWSE it still show the numbers swithout a leading zero. 

- Also when I use the AI DATA SOURCE WIZARD to create barcodes, the data format for GTIN remains as 13 characters even when I change the data source to 14 characters.

- AI 22 is obsolete, however it still shows up on my list on Bartender. How do I update my software?

 

Can someone please guide me through this as I am new to using Bartender.

 

Thank you.

6 commentaires

0
Avatar
Legacy Poster
Actions pour les commentaires Permalien

In your database setup, can you change the datatype on the field to be text instead of number?

0
Avatar
Legacy Poster
Actions pour les commentaires Permalien

In your database setup, can you change the datatype on the field to be text instead of number?

Hi Slickson,
 
Thank you for your reply.
 
I am quite new to using Bartender, so could you please direct me step by step as to how I can change it?
 
As of now I could not find the option to change it to text on database setup (Bartender version 10.0 SR4).
 
Thanks

0
Avatar
Legacy Poster
Actions pour les commentaires Permalien

I just checked and you may need to reload/refresh your database after playing with the column format in Excel.  The Excel Data source does not allow you to specify the data type, I was thinking of the Text file data source.

0
Avatar
Legacy Poster
Actions pour les commentaires Permalien

I just checked and you may need to reload/refresh your database after playing with the column format in Excel.  The Excel Data source does not allow you to specify the data type, I was thinking of the Text file data source.

Yup done that as well and still the same result.

0
Avatar
Legacy Poster
Actions pour les commentaires Permalien

hi, any one have the solution to this issue bring out by pratik789 above?

 

 

 

 

 

 
0
Avatar
Legacy Poster
Actions pour les commentaires Permalien

Trying adding an extra row at the top of your database with a value of "dummy record" or similar across all the fields..  

 

Sometimes the ODBC driver ignores the settings and looks at the data in the first few records and so where you have just numbers in a column it processes the column as if it were always a number and not as a "Text" field even if you have set it as such.  Adding letters into the first record sorts this out.

 

You can get the same result where your data starts off as numbers in a column and changes to text in later records in the table and so these later fields appear as blanks on the label or else can trigger errors in the case of numeric only barcodes.

Vous devez vous connecter pour laisser un commentaire.