Aller au contenu principal



Labels pausing between labels with Commander


2 commentaires

  • Avatar
    Travis Truax

    I've seen this before as well, but unfortunately I don't remember exactly how we resolved it.

    When you say that they prints without pause through Bartender, how are you testing that? An avenue of research I would explore is what actions the commander process is taking vs what bartender takes. I believe on some printers (like Zebra) the label format is cached in the printer when you print a group of labels at once, and just the changed field data is sent for subsequent labels in the group, but in this scenario with Commander, each file may trigger the entire format to be sent. (Of course, your format may be very small or very large - I have no idea...)

    For testing purposes, can you doctor one of your commander trigger files to contain 2 labels? If that doesn't cause a delay, it may help to point out where the delay is occurring. Just thoughts...



  • Avatar
    Jasper Wen

    If you a sending a trigger file like you mention through Commander, it should be sending it as one print job. It is interesting you say printing directly through BarTender with this same data has no issues.

    If you are printing a lot of records, I would recommend the following to improve performance:

    • Make sure you are using a Seagull printer driver (if available depending on printer)
    • Use printer fonts instead of Windows true type fonts
    • Printer performance optimizations are enabled. In BarTender by default, under file->print and performance tab, all the options should be checked except graphic and template caching. In the object print method, the true type text should be set to text output and other options set to auto.
    • Try using local directories and printers instead of network locations to see if that improves performance.

    You may also want to confirm in Commander the trigger is being detected in timely manner by looking at the logging pane. In addition, as a test and to narrow down the issue, you may try running in application mode with visible Windows. This will allow you to see how Commander runs BarTender in the background by doing the following that might give you some hints (this will require you to stop Commander detection):

    • In Commander, go under administer->service setup and change to application.
    • Next go under detection->command handler setup->general tab and set visible windows to all.
    • Start detection and send a trigger.

Vous devez vous connecter pour laisser un commentaire.