Option Not Available To Start Sls As A Service. S’abonner

0
Avatar
Legacy Poster

Hello,

 

I currently have an issue where the option to start as a service is not available in the SLS application. Also SLS does not appear in the services list when clicking the manage services button. I have tried logging into an administrator account to no avail. I have considered re-installing the software but I don't want to exceed the the transfer limit if I uninstall then re-install the software.

 

 

13 commentaires

0
Avatar
Ian Cummings
Modérateur
Actions pour les commentaires Permalien

Open a command line prompt window (CMD) and enter in the following command line:
 
sc.exe create "Seagull License Server" binPath= "C:\Program Files (x86)\Seagull\BarTender Suite\slssrv.exe"
 
*Note the space between the "binPath=" and the "C:\Progra..." part of the command line.  Important that you don't remove this.
0
Avatar
Legacy Poster
Actions pour les commentaires Permalien

That worked to add the service but I ran into more issues. When I try to start the service I get Error 1053. I have the service set up to log in as the local admin so it should have the permissions to start the service but its not responding in a timely fashion.

[attachment=1443:Bartender Error.png]

0
Avatar
Ian Cummings
Modérateur
Actions pour les commentaires Permalien

This sounds like it might be a problem with checking the publisher's certificate revocation.
 
BarTender is a native Windows application developed in C++ and MFC (Microsoft Foundation Class).  However, some of BarTender's functions are based on .NET Framework 2.0 technology.  For any .NET Framework 2.0 application if the below security setting is enabled, it can cause BarTender, License Server or any BarTender Suite service to start slowly or to not start at all. 
 
One solution to this problem is to change the below "Internet Option" so from the "Start>Control Panel>Internet Options" item, under the "Advanced" tab, disable the "Check for publisher's certificate revocation" option.  This setting is a per user setting and will only apply to the current user you're logged in as.  Otherwise, open up Notepad, paste in the below registry entries text, and save as a .reg file.  Once done double click the file to modify the system registry at the HKEYS defined.
 
Windows Registry Editor Version 5.00

[HKEY_USERS\S-1-5-18\Software\Microsoft\Windows\CurrentVersion\WinTrust\Trust Providers\Software Publishing]
"State"=-

[HKEY_USERS\S-1-5-18\Software\Microsoft\Windows\CurrentVersion\WinTrust\Trust Providers\Software Publishing]
"State"=dword:00023e00

 

0
Avatar
Legacy Poster
Actions pour les commentaires Permalien

I fixed the registry and it works great now, Thanks!

 

Edit: The fix did not work after 1 day.

0
Avatar
Legacy Poster
Actions pour les commentaires Permalien

I believe the registry was fixed and the licence server seemed to run fine but today i got a message saying bartender had been disconnected for 1 day. I tried to fix the registry again and it did not help I tried fixing the internet options on both the logged in user account and the account the service uses to run and that did not help either. 

0
Avatar
Ian Cummings
Modérateur
Actions pour les commentaires Permalien

Did you check to see if the service is running or not.  All that you've told me is that BarTender was no longer connecting.  There can be various reasons for that happening.

0
Avatar
Legacy Poster
Actions pour les commentaires Permalien

Sorry, I did check it is not. I still get the windows failed to start the service message.

0
Avatar
Ian Cummings
Modérateur
Actions pour les commentaires Permalien

What account is the service logging on as?  Normally it should run under the "SYSTEM" account.  If under a user account then log on as that account and untick the "Check for publisher's

certificate revocation" option in the "Internet Options" item from the Windows Control Panel.  See the attached screenshot.

0
Avatar
Legacy Poster
Actions pour les commentaires Permalien

The service is currently set up to use the local admin account "Administrator" to log on. When i log into that account on the computer this box in unchecked, I tried un-checking it previously in hope that it would solve the problem.

0
Avatar
Ian Cummings
Modérateur
Actions pour les commentaires Permalien

You should run it as the default "Local System Account".  There is no need to specify an particular account for this service to run under.

0
Avatar
Legacy Poster
Actions pour les commentaires Permalien

How do you set up a service to run as the default "Local System Account"?

0
Avatar
Ian Cummings
Modérateur
Actions pour les commentaires Permalien

Open the service properties, select the "Log On" tab, click the "Local System account" radio button.  The "Allow service to interact with desktop" checkbox is optional, and can be enabled if you wish.

0
Avatar
Legacy Poster
Actions pour les commentaires Permalien

Open the service properties, select the "Log On" tab, click the "Local System account" radio button.  The "Allow service to interact with desktop" checkbox is optional, and can be enabled if you wish.

 

 

This is how it is set up and it still gives the same windows error.

Vous devez vous connecter pour laisser un commentaire.