Printing More Than 255 Characters On A Label S’abonner

0
Avatar
Legacy Poster

I have product label that is using excel as its databse.

One of the text fields (ingredients) sometimes has more than 255 characters.

 

I found that it only prints up to 255 characters.

 

How do I print more than 255 characters.

Any help is appreciated.

 

I am using Bartender Automation V10

 

Thanks

5 commentaires

0
Avatar
Domingo Rodriguez
Modérateur
Actions pour les commentaires Permalien

What Edition, version  and build of BarTender is in use?

 

What Version of Microsoft Excel?

 

What OLE DB driver are you using to connect to your Excel spreadsheet, is it the Ace or Jet one?

 

A quick workaround would be to save your Excel spreadsheet as a comma separated value file (.csv), and then import to this file instead via BarTenders "File > Database Connection Setup" dialog (as a text file, not as an Excel spread sheet).

 

The underlying problem is that the ACE driver is inferring a TEXT data type for the column when you're populating the data set. Text columns are limited to 255 characters.

0
Avatar
Legacy Poster
Actions pour les commentaires Permalien

thank you for your response.

I am using

Bartender Automation V10.0 Build 2821

Windows 7 Professional x86 SP1

Microsoft Office Professional Plus 2010 Version 14.0.6129.5000 (32-bit)

 

How can I tell what OLE DB driver I am using (ACE or JET)?

How can install alternate driver?

Is there any workaround to continue to use excel (since it easier for staff to update and use)?

Will changing any of my excel column data types make any difference?

would upgrading excel to 2013 make any difference?

 

I will try csv in the meantime

Thank you in advance for your help

0
Avatar
Legacy Poster
Actions pour les commentaires Permalien

I connected using ODBC rather than OLEDB and it fixed my problem.
I can now print more than 255 characters on a label.
 
However,
a different problem has emerged.
Some of the fields are being treated as number data type and Bartender is adding .0 ot the end.
This does not allow it to interpret the barcode field correctly.
 
Is there a way of forcing certain fields to be a certain data type when connecting using ODBC?
Thanks

 

I will try and workout how to upload some photos to show you some of the screens

0
Avatar
Domingo Rodriguez
Modérateur
Actions pour les commentaires Permalien

Just open the properties for this BarTender object, select the corresponding data source, now select the "Transform" tab, click the "Truncation" button and now enable "Strip .0 or ,0 from value" checkbox.

 

Please see the attached Microsoft Excel troubleshooter as well for your reference.

0
Avatar
Legacy Poster
Actions pour les commentaires Permalien

Thank you,

your pdf solved the problem.

the solution for everyone that may need it is:

 

Make sure you have two dummy rows at the top of your excel spreadsheet with any fields (columns) that require to be treated as memo fields populated with more than 255 characters.

When connecting to the excel spreadsheet, bartender will assume they are memo fields (greater than 255 characters allowed).

Thank you for your help.

Alexander

Vous devez vous connecter pour laisser un commentaire.