Quotes symbols. S’abonner

0
Avatar
Eugene GP

Russian version of BarTender 11 have some problems with quotes symbols. Script Editor replaces "" on «».

When I start my old sctipt (it created in 10.1) I get error OnFillList (Line 1): Value = «Значение 1» + vbCr + «Значение 2»: Недопустимый  знак. On English: OnFillList (Line 1): Value = 'Value 1' + vbCr + 'Value 2': Invalid character.

I get this in any case, even when I do not use the Text Input Box. I use Windows 10 and Russian as default language.

 
 
G
M
T
 
Определить язык Азербайджанский Албанский Английский Арабский Армянский Африкаанс Баскский Белорусский Бенгальский Бирманский Болгарский Боснийский Валлийский Венгерский Вьетнамский Галисийский Греческий Грузинский Гуджарати Датский Зулу Иврит Игбо Идиш Индонезийский Ирландский Исландский Испанский Итальянский Йоруба Казахский Каннада Каталанский Китайский (Упр) Китайский (Трад) Корейский Креольский (Гаити) Кхмерский Лаосский Латинский Латышский Литовский Македонский Малагасийский Малайский Малайялам Мальтийский Маори Маратхи Монгольский Немецкий Непали Нидерландский Норвежский Панджаби Персидский Польский Португальский Румынский Русский Себуанский Сербский Сесото Сингальский Словацкий Словенский Сомали Суахили Суданский Тагальский Таджикский Тайский Тамильский Телугу Турецкий Узбекский Украинский Урду Финский Французский Хауса Хинди Хмонг Хорватский Чева Чешский Шведский Эсперанто Эстонский Яванский Японский   Азербайджанский Албанский Английский Арабский Армянский Африкаанс Баскский Белорусский Бенгальский Бирманский Болгарский Боснийский Валлийский Венгерский Вьетнамский Галисийский Греческий Грузинский Гуджарати Датский Зулу Иврит Игбо Идиш Индонезийский Ирландский Исландский Испанский Итальянский Йоруба Казахский Каннада Каталанский Китайский (Упр) Китайский (Трад) Корейский Креольский (Гаити) Кхмерский Лаосский Латинский Латышский Литовский Македонский Малагасийский Малайский Малайялам Мальтийский Маори Маратхи Монгольский Немецкий Непали Нидерландский Норвежский Панджаби Персидский Польский Португальский Румынский Русский Себуанский Сербский Сесото Сингальский Словацкий Словенский Сомали Суахили Суданский Тагальский Таджикский Тайский Тамильский Телугу Турецкий Узбекский Украинский Урду Финский Французский Хауса Хинди Хмонг Хорватский Чева Чешский Шведский Эсперанто Эстонский Яванский Японский          
 
 
 
Звуковая функция ограничена 200 символами

5 commentaires

0
Avatar
Shotaro Ito
Actions pour les commentaires Permalien

It looks there's problem in BarTender. Reported to development division.

As workaround, please switch BarTender's language settings from Tools menu > General options. 

0
Avatar
Eugene GP
Actions pour les commentaires Permalien

I tried it. It did not help.

0
Avatar
Shotaro Ito
Actions pour les commentaires Permalien

For some reason, affected document's script might already be modified and saved.

In English UI, Try replace « to " etc and save to see you can fix and keep the setting.

You could contact to Tech Support too.

0
Avatar
Eugene GP
Actions pour les commentaires Permalien

I also tried it. It also did not help. It seems BarTender writes «» in btw file and next file save can not fix the error.

0
Avatar
Shotaro Ito
Actions pour les commentaires Permalien

By switching My windows language setting from Japanese to Russian I could see similar issue,  and once BarTender language set to English and edit VB script to use  proper quotation " " for string and saved, it looks working - however I don't have your document nor Russian windows so condition is not same. I recommend contact to support with the btw document attached.

Vous devez vous connecter pour laisser un commentaire.