Aller au contenu principal

Recherche

Recherche

Bartender delay in print with Integration builder

Commentaires

11 commentaires

  • Avatar
    Seb Atkins

    Is the printer you are printing to installed directly on the server/pc or is it a shared printer from another machine? This could definitely cause some slow down.

    Have you checked the available resources on the PC/Server? i find having the administration console open while trying to monitor these things can soon take up a lot of memory (i have seen this snowball up to 12GB when i have accidentally left the message log window open) which obviously then slows everything down.

    I find if you open up the administration console and then go into the integration message log and close it down, when you re-open it it does keep a log of the history or maybe even try checking the SystemDB itself for the message log. this might give you a more accurate timescale of how long the jobs are taking to go through without the administration console eating up resources.

    0
  • Avatar
    Permanently deleted user


    Hi Seb,

    The printer is installed on the server. And I am using the option test integration. I did not open any console. I see the messages in the output section of the Test Integration.

    Please see the attached screen shots.

    0
  • Avatar
    Seb Atkins

    Looking at the screenshot it seems to be hanging when executing the bartender print command script.

    I don't have much experience with the command scripts so correct me if i am wrong but on first glance it looks as though you are referring to the document and printer via UNC paths "\\GBOROSRV02" this would cause it to look for the document and printer over the network rather than locally on the server.

    If the document and printer are installed on the server itself then i would use the true filesystem paths rather than UNC ones example "C:\Filepath\blah\B46.btw" and for the printer it would just be the printer name so "GBBT02"

    Seb

    0
  • Avatar
    Charles Serwin

    I was wondering if any resolution was found for this issue.  We have a similar issue in our company where there is now a huge delay between when Bartender processes the file and when it places the file in the print spooler queue.  It went from 2-3 seconds to well over 80 seconds.  I suspect it was caused internal to our company since two major Bartender systems have similar systems and starting having the issue at around the same time.

    0
  • Avatar
    Len Ott

    Did anyone ever resolve this? I am seeing this now also.  With Bartender10, I never had such issues.

    0
  • Avatar
    Carlos Aguirre

    I see this thread is quite old now, I'm seeing the exact same behavior described on top of this article, in our case the delay is around 10 secs or so to see the print request who up in the printer queue after Bartender reports that print command has been processed correctly. Using Bartender 2019 and Windows 2019 with local printers and Zebra Seagull printer drivers

    0
  • Avatar
    Charles Serwin

    Here was the solution that worked for us per Bartender 2nd tier tech support.

     

    Hello,

    My name is Raul and I will be working with you on this issue. After looking over the logs and notes for this ticket I think I know what is happening and have a suggestion. In order to implement this suggestion you will need to stop your integration for about 5 minutes, please plan a time to implement this.

    he following goes over the steps on how you may change or configure these settings:

    1. Before starting, make sure your Integration is stopped. If it's running Stop it by opening Administration Consolve > Integrations and click Stop all.
    2. Go into the Windows Services list. Find the BarTender Print Scheduler Service and also stop this service.
    3. Go to the main BarTender Installation directory. By default it is C:\Program Files (x86)\Seagull\BarTender Suite (32 bit installation) or C:\Program Files\Seagull\BarTender Suite (64 bit installation). Find and open the PrintScheduler.Service.exe.Instance.config file in this directory.
    4. Find "DynamicEngineScaling and StartOndemand, set the to false like the example below:
    • DynamicEngineScaling="false"
    • StartOnDemand="false"
    1. Save the changes and close the file
    2. Restart the Print Scheduler service and your Integration.



    0
  • Avatar
    Carlos Aguirre

    Thanks Charles and Raul for taking this up,

    Unfortunately no significant change in time that it takes to reach the print spooler every print request after the print command has been processed by Integration Services (around 5 secs)

    See screenshot showing when the print command has been submitted and how much it takes for the print request to reach the printer spooler, I'm working this using Test functionality of Integration Services

    0
  • Avatar
    Paul Nolan

    I am also seeing this behavior on 2022 R2.  It's actually worse than the previous version we were on (2021 R7).

    0
  • Avatar
    Utah Taylor

    Has anyone on this thread noticed a difference between networked and client printers? I am having this same issue and am about to see if there's a difference in the printer type (networked vs client).

     

    0
  • Avatar
    Jeff Sergeant

    We had this exact problem and it seemed to be that the bartender.exe was taking a long time to load the label designs before printing. The root cause was that the label files had references in them to files or paths that do not exist.

    If you have database connections pointing to files on shares that the integration service could not see (Even if the labels are given a data file at print time,  it seems to try to load the 'default' when opening the file for the first time),  or 'images' set with a default path that the integration service could not access (Again, even if these are replaced in script during printing, the 'default' paths are checked on load)

    Updating the labels to remove any references to inaccessible shares seems to have resolved the issue.

    0

Vous devez vous connecter pour laisser un commentaire.