Safe to uninstall SQL Server Compact 3.5 SP2? S’abonner

0
Avatar
Papp diin

We're running BarTender v2016 R9 on a server using only the integration feature that reads a flat file and prints it.

The SQL Server Compact 3.5 SP2 was installed on the system as part of the BarTender installation, but is now flagged as an unsupported (End Of Life) product by our IT and must be uninstalled.

Can this be done without disturbing the functionality of the BarTender software. We are not using the system database feature (although I'm not sure if it's related to that at all).

On the system there's also SQL Server Compact 4.0 installed, which seems to still be ok for another year.

 

Thanks for any help!

8 commentaires

0
Avatar
Al Perez
Modérateur
Actions pour les commentaires Permalien

Hello Papp, thank you for your question.

SQL Server Compact 3.5 SP2 is needed by BarTender 2016; please note, SQL CE is not SQL Server or SQL Express. It is installed so that a set of libraries that enables accessing a file using relational database methods - it is a programming tool.

If you have further questions or concerns, please reach out to us again here, or please start a new case with our technical support team here.

I hope that helps!

0
Avatar
Papp diin
Actions pour les commentaires Permalien

Ok good to know. And yes, I know that it's not a SQL Server per se :)

Can you tell if it has changed in the 2019 version of BarTender? Is there still a dependency on SQL CE and in that case what version?

0
Avatar
Al Perez
Modérateur
Actions pour les commentaires Permalien

Hi Papp, thanks for your question. 

As far as BarTender 2019 goes, it requires only Compact 4.0 (installed when you install BarTender). Microsoft is committed to supporting it through July 2021 at present, if you're looking for this information.

0
Avatar
Papp diin
Actions pour les commentaires Permalien

Ok. Can you tell me when you're planning on dropping the SQL CE requirement, and in what version? I assume it's before July 2021?

0
Avatar
Al Perez
Modérateur
Actions pour les commentaires Permalien

Hi Papp,

Because SQL CE is a development tool used for BarTender, I don't know that we'll ever see it being dropped; it's certainly not information that the developer will let us know until it actually happens. At this point, there's no information on that, unfortunately, that's the best I can give you. Sorry!

0
Avatar
Papp diin
Actions pour les commentaires Permalien

Hmm...

Myself working as a system/software designer/developer I usually prefer to get rid of abandonware components as quickly as possible. It doesn't sound good if your development team doesn't havae a plan to phase out this dependency within the coming 6 months.

Anyhow, I've got information that some machines doesn't have this component installed (at least not listed in Windows add/remove programs list). Could you shed some more light on exactly what features in BarTender is actually utilizing this SQL CE component.

 

Thanks!

0
Avatar
Al Perez
Modérateur
Actions pour les commentaires Permalien

Hi Papp, thanks for your continued support.

You are more than welcomed to open a Technical Support ticket regarding SQL CE, but as far as we know, BarTender actually uses it - it is not abandonware. While I cannot specify how it's used in our Community board (for lack of knowing), opening a TechSupport ticket would allow a Technician to open some dialog with the development team to give you an answer. Ultimately, it's a requirement (I'm sure you already understand that).

To summarize, I cannot shed more light on your question - please reach out to Tech Support here.

Thank you!

0
Avatar
Papp diin
Actions pour les commentaires Permalien

So I tried to figure out myself if both 3.5 and 4.0 are actually needed in 2016R9.
We're mostly using it to integrate label printers to a MES system using the file integration feature so that was what I looked most into to.

These were my conclusions:
SQL CE 3.5 doesn't seem to cause anything to malfunction from a quick look around. However removing both 3.5 and 4.0 seemed to cause some serious issues in Printer Maestro.
This showed up in Windows Event Viewer when 4.0 was removed too;

Also the Integration -> Deployment view in Administration Console is becoming empty

Tried to find sdf files in C:\ProgramData\Seagull and found 4 files with that extension. Managed to open two of them in LinqPad;

From the names it clearly explains why integration view is empty as it seems like that first file contains the data for it.

Vous devez vous connecter pour laisser un commentaire.