Cache Problem フォローする

0
Avatar
Legacy Poster

I have two data files with different label formats and printers (see below). When these two files are dropped to the folder at the same time commander always print the same label format (say FUTUREREEL.btw) on both label printers instead printing FUTUREREEL.btw on printer 4x2 and FUTUREPACK.btw on 4x6. Is this a cache problem?

 

Data File1:

%BTW% /AF= "C:\BarTender\SAP\LabelFiles\FUTUREREEL.btw" /PRN="4X2" /D="%Trigger File Name%" /DBTEXTHEADER=3 /R=3 /P /C=1
%END%
<Data>

 

Data File2:

%BTW% /AF= "C:\BarTender\SAP\LabelFiles\FUTUREPACK.btw" /PRN="4X6" /D="%Trigger File Name%" /DBTEXTHEADER=3 /R=3 /P /C=1
%END%
<Data>

 

Thanks,

-Tong Qu

11 コメント

0
Avatar
Fernando Ramos Miracle
モデレータ
コメントアクション Permalink

Hello Tong,

 

I certainly don't see nothing wrong with your Commander script that could cause this.

 

1. If you run Commander as an application (from the "Administer>Service Setup..." option) do you get the same issue?

 

2. When this happens do you see Commander applying the correct command (on the Commander log)?

 

3. Could you let me know what exact printer brand and model are you working with? If it's a thermal printer we support, could you make sure to download and install our latest Seagull drivers (v7.3.4)? you'll find them on the below webpage:

http://www.bartenderbarcodesoftware.com/drivers/windows-printer-drivers-download.aspx

 

4. What version edition and build of BarTender are you working with?

 

Regards,

0
Avatar
Legacy Poster
コメントアクション Permalink

Guru,

1. Commander is running as Application;

2. The Commander log does show right information. Please see the attachment.

3. We are using Zebra label printers. LP2844 and GC420d

4. Please the attachments

0
Avatar
Fernando Ramos Miracle
モデレータ
コメントアクション Permalink

Hello Tong,

 

1. If running as an application is still causing your this issue, this is certainly not a memory related problem.

 

2. Could you confirm me that when you send either of the trigger files separately you get the correct print out?

 

3. Could you access the "User Account" tab from Commander's "Detection>BarTender Command Handler setup..." dialog and let me know if you've specified a user account there?If so please make sure to remove it and try again, do you get a better result?

 

4. How exactly are these Zebra printers connected to this computer? Are they locally installed, using a networked TCP/IP port, shared driver from a different computer or server...?

 

Could you attach the Commander task list (.tl file) so we can take a look at it?

 

Regards.

0
Avatar
Legacy Poster
コメントアクション Permalink

2. If I send the trigger files separately the first set came out OK. After that it printed the same label format again on both printers.

3. Detection>BarTender Command Handler setup is greyed out.

4. The Zebra printers are locally connected to the computer.

 

The .tl file is attached.

0
Avatar
Legacy Poster
コメントアクション Permalink

Attached screenshot of BarTender Command Handler setup.

0
Avatar
Fernando Ramos Miracle
モデレータ
コメントアクション Permalink

Hello Tong,

 

Taking a look at your task list and pdf I don't see anything wrong on the actual Commander configuration, so the issue must be elsewhere.

 

1. Could you please clarify what yo mean with "After that it printed the same label format again on both printers"? Do you get the same label printed on both printers regardless of the trigger file sent after the first one? Or is it that the label gets duplicated printing on both of your printers?

 

2. Could you please attach one of your trigger files so I can take a look at it?

 

3. Could you also attach the related BarTender document?

 

4. Also, could it be possible that some other Commander instance is scanning that same folder?

 

5. Could you please activate BarTender print job logging from the "Administer>Log Setup..." option (under the "Text File Log" tab)? Once done so please reproduce your issue and verify exactly what BarTender is doing, what print job is sending and to which printer.

 

Do attach this log so I can also take a look at it.

 

Regards.

0
Avatar
Legacy Poster
コメントアクション Permalink

Sorry, I was tied up on something else and didn't have time to reply your message. May I talk to you on GoToMeeting so you can see what's going on my end? Do you have email address so I can send the invite to you?

0
Avatar
Legacy Poster
コメントアクション Permalink

To answer your question:

1. If I have two trigger files that print 2 different labels and if I wait long enough or just after the commander is restarted I will get 2 labels printed correctly. But after that the commander somehow only prints one label format on 2 printers.

2. Trigger files attached.

3. Bartebder documents attached.

4. There is no other commander instance running on this machine. Everything on the computer is local.

5. This is very strange: I enable the Text File Log but no txt file was created (by default CmdrMsg.txt). If I manually create the txt file in the folder it gets deleted after the commander is triggered.

 

That's why I like you to take a look at my machine. Maybe we are doing something not quite right.

0
Avatar
Fernando Ramos Miracle
モデレータ
コメントアクション Permalink

Hello Tong Qu,

 

Thanks for the files.

 

After taking a look at your documents I noticed that they are both saved to the same printer driver (named "4x2"), could this be the printer that receives the two print jobs? If that is the case it might be a problem of the print order loosing the printer definition and reverting back to the default setting.

 

1. As a first step, I see that you are working with ZDesigner drivers for your printers, could you instead download and install our Seagull drivers from the below webpage? Do you get the same issue when working with our drivers (make sure to open your document, select these new drivers and close it before testing it with Commander)?

http://www.bartenderbarcodesoftware.com/drivers/Zebra-windows-printer-drivers.aspx

 

2. In any case, we really would need Commander and BarTender to generate the text file log. Could you make sure that the user under which the Commander service is running has enough access rights over the folder where BarTender/Commander is supposed to generate the log?

 

*It's probably better to escalate this issue to a direct contact with our Technical support department (especially if we maybe need to connect to your computer), could you please send the above logs to our Tech Support email? You'll find its details on the below webpage:

http://www.bartenderbarcodesoftware.com/label-software/technical-support.aspx

 

Regards,

0
Avatar
Legacy Poster
コメントアクション Permalink

I did updated all of our label printers to Seagull printer drivers, and it didn't fix our issues. So I'll contact Technical Support for more help. Thanks for you help and support.

0
Avatar
Legacy Poster
コメントアクション Permalink

Got help from Tech support through GoToMeeting. Now commander is working properly. Thanks again.

ログインしてコメントを残してください。