Commander Not Executing All Files フォローする

0
Avatar
Legacy Poster

We have a commander installation (7.51) running on a Windows XP box
and a single task reading a directory on a share drive to print labels
created from Bartender.

It is using Commander Script to trigger the command automatically from the header of the file. The directory for this task is being polled every 5 or 10 seconds.

The first line of the file contains the design, printer name and the number of labels to print:

 

%BTW% /F=C:\bartender\label.btw /D=<Trigger File Name> /PRN="Printer Name" /C=1 /S=1 /P

 

Frequently we need to generate labels in quick succession, (in a matter of a minute or two) with multiple files being created.

Sometimes,
when several files, maybe a dozen or so are in the directory it appears
some labels do not print, even though it appears the label has been
processed.

 

All
the files are renamed and saved with a new extension as expected,
however in the log section of Commander screen, one file that are not
processed or a label generated:

 

[Task Name] Labels
[Date/Time] 17/05/2016 4:13:15 PM
[BarTender
Command] Command Handler: BarTender1 -
C:\PROGRA~1\Seagull\BARTEN~1\7.51\bartend.exe /F=C:\bartender\label.btw
/D=C:\bartender\Data\LABEL1234.sav /PRN="Printer Name" /C=1 /S=1 /P

[Task Name] Labels
[Date/Time] 17/05/2016 4:13:20 PM

[Task Name] Labels
[Date/Time] 17/05/2016 4:13:25 PM
[BarTender
Command] Command Handler: BarTender1 -
C:\PROGRA~1\Seagull\BARTEN~1\7.51\bartend.exe /F=C:\bartender\label.btw
/D=C:\bartender\Data\LABEL1236.sav /PRN="Printer Name" /C=1 /S=1 /P

 

As
you can see, the first and third label has a command in the log and a
label was generated for these files. However, the second one has a blank
"command".

Renaming the file manually to the files to be scanned for extension, it works OK if there are no other files in the directory.

 

This is becoming a continued issue, and labels are reprinted again or manually changed to get the label out.

What could be causing the files from being skipped or Commander not executing the files altogether?

 

Thanks.

1 コメント

0
Avatar
Ian Cummings
モデレータ
コメントアクション Permalink

I suggest you work through the Commander trouble-shooter.

 

http://forums.seagullscientific.com/index.php?/topic/55-commander-troubleshooting/

サインインしてコメントを残してください。