Labelformatdocument フォローする

0
Avatar
Legacy Poster

hello

Enterprise Automation edition is required for LabelFormatDocument??
can i use it with Automation edition??

12 コメント

0
Avatar
Ian Cummings
モデレータ
コメントアクション Permalink

The LabelFormatDocument() class is of the Seagull.BarTender.Print namespace in the .NET component. This is supported by the Automation edition. Can you tell me where you have seen that it needs the Enterprise Automation edition?
-1
Avatar
Legacy Poster
コメントアクション Permalink

on this code line
LabelFormatDocument btFormat = btEngine.Documents.Open(templatePath);
it gives error "3126 Automation call requires the Enterprise Automation edition"
0
Avatar
Ian Cummings
モデレータ
コメントアクション Permalink

Could it be that the label document itself is using a feature that is not supported by the Automation edition? Try creating a very simple document and have your application open that instead. The line of code in itself is supported by the Automation edition, period, so there is obviously something else going on here.
0
Avatar
Legacy Poster
コメントアクション Permalink

hello
i have created new template with automation edition (for ur information i m using trial version on bartender)
But still getting same error.

created template with barcode font name (code 128) and bind with data source text file
0
Avatar
Ian Cummings
モデレータ
コメントアクション Permalink

Check via the "Help>About" menu item in BarTender and tell me how many trial days are left. It should be noted that when the trial period has expired the testing of program controlled automation will fail.
0
Avatar
Shotaro Ito
モデレータ
コメントアクション Permalink

If you use BarTender 10.0 SR1, Select "Enterprise Automation" edition from Help > Edition selection.
10.0SR1's new feature Edition selection works fine in BarTender UI, however not perfectly supported in Automation domain yet.
On trial, please consider Enterprise Automation edition when you use functionality below.

SDKs only supported by Enterprise Automation Edition.
[list]
[*]BarTender .NET Librarian SDK
[*]BarTender .NET Print Server SDK
[/list]
In BarTender .NET Print SDK, Properties and methods below are only supported by Enterprise Automation Edition.
[list]

[*]Engine.CommandLineCompleted Event
[*]Engine.XMLScript Method
[*]PrintSetup.PrintToFileLicense Property
[*]Prompts.LayoutXML Property
[*]LabelFormatDocument.ExportPrintPreviewRangeToFile Method
[*]LabelFormatDocument.ExportPrintPreviewToFile Method
[/list]
0
Avatar
Ian Cummings
モデレータ
コメントアクション Permalink

As per Shotaro's post, could you tell us what edition the Trial is running as? This is set via the "Help>Edition selection" menu item. By default it should be the Enterprise Automation edition.
0
Avatar
Legacy Poster
コメントアクション Permalink

using Automation Edition.
yes still 15 days remaining of trial version
0
Avatar
Ian Cummings
モデレータ
コメントアクション Permalink

As a test, if you run the Trial as an Enterprise Automation edition does it then work correctly via automation?
0
Avatar
Legacy Poster
コメントアクション Permalink

Just wanted to add a "me too" to this thread.

Dim document As LabelFormatDocument

Dim myBarTenderEngine As New BarTenderEngine
document = myBarTenderEngine.BtEngine.Documents.Open(Path.Combine(Path.GetDirectoryName(Application.ExecutablePath), "Resources\unit.btw"))

Getting an "3126 Automation call requires the Enterprise Automation edition" error on above line when using the trial edition V10.0 SR1 Build 2845 and choosing Automation Edition. The error does indeed go away if I switch to Enterprise Automation edition.

Again this is with the Trial.

Same code worked perfectly with our licensed 9.4 version Automation edition. Was just testing with v10.0 before we upgrade. Is this a problem only with the trial or will we experience it with the licensed Automation edition as well?

Greg
0
Avatar
Ian Cummings
モデレータ
コメントアクション Permalink

This is just a known problem with the new "Edition Selection" feature of BarTender, which by its nature is only of use when running as a Trial or if you are a BarTender reseller. The problem being that the edition selection breaks the edition check mechanism when running BarTender via automation. This will be fixed in the forthcoming v10.0 SR2. For end-users of the full edition this isn't really an issue because you would run the software as the edition that was purchased.
0
Avatar
Legacy Poster
コメントアクション Permalink

Hi!

 

I'd like to feedback on what happened to me!

 

I had installed BT Automation on one PC, logged in with my personnal account, but with Local Admin rights. Of course, I had selected the Automation Edition and everything worked just fine... for me!

 

But then I asked another user to log in - just to complete the test and I received the "3126 Automation call requires the Automation Edition" message.

Reading this post, I went to the Help/Edition Selection menu and realised that for this user, BT was runing in "Basic" mode!

Selecting Automation Edition did the trick...

 

Cheers,

Stephan

 

PS: I'm using 10.1 SR3

ログインしてコメントを残してください。