Sls Service Not Started フォローする

0
Avatar
Legacy Poster

Hi,

We have a vendor performing some IBM Tivoli Maximo customization for us, and a couple months back they installed the BarTender software. Since they are still working on things we did not have occasion to actually test out BarTender until recently.

Apparently SLS service has trouble starting, we get an error message saying "The Seagull License Server could not be started as a Windows service. Unknown error."

Any ideas as to what to check first?

7 コメント

0
Avatar
Susan Chen
モデレータ
コメントアクション Permalink

Hi, Imranf:

It look like you are getting 3611: The Seagull License Server could not be started as a Windows service. The most likely causes are below:

1. Seagull License Server (SLS) is not activated.
2. A special error that would only happen if you don't have at least .Net Framework 2.0 SP2 on your system.
3. SLS service does NOT have enough permissions to run.

Please check/perform the following depending on his issue:
1. Check that SLS is activated. From SLS, go to "Help->About" menu and see if it's activated.

2. From Add/Remove Programs, check the .Net Framework version that's installed. If .Net Framework version is not at least .Net 2.0 SP2, please upgrade your .Net version to the newest version.

3. Add an account w/ enough permission to run to the Seagull License Server service:
From Windows' Start->Run, type "services.msc" and click "OK".
Double-click on "Seagull License Server" and under the "LogOn" tab, enter the account information.




Thanks!
0
Avatar
Legacy Poster
コメントアクション Permalink

Thank you for your response!

1. Clicking on Help->About shows following information displayed:
Edition: Enterprise
Version: 9.10
Build : 2617
Activation Status: Activated
Serial Number: [i]<omitted>[/i]

2. SLS is installed on a Windows Server 2003 R2 Enterprise OS. According to Add/Remove programs, the Microsoft .Net Framework 2.0 is already present.

3. Under the Log On tab ("Log on as:"), the first checkbox is marked ("Local system account"), although the option below it ("Allow service to interact with desktop") is not marked.


Apparently previously we did have a test print after the software was first installed and it did work. However, our problem now is that the SLS service is not started when we reboot the server. Attempting to start the service manually from the Control Panel -> Administrative Tools -> Services -> Seagull License Server results in an error message saying "Could not start the Seagull License Server service on Local Computer. Error 1053: The service did not respond to the start or control request in a timely fashion."

Thank you.
0
Avatar
Domingo Rodriguez
モデレータ
コメントアクション Permalink

I've attached a ZIP file to this topic: [b]1053_Fix.zip[/b]. Please run it. It will disable a known Internet Explorer security setting for the "Local System" Windows account (called "check for publisher's certificate revocation") which avoids some services, based on .NET Framework 2.0, to be started.

BarTender is a native Windows application developed in C++ and MFC (Microsoft Foundation Class). However, BarTender’s interface (includes Commander, Printer Maestro, Seagull License Server) is now based on .NET Framework 2.0 (and part of .NET Framework 3.5).

After running the attached ZIP file, the registry will be modified so that this Internet Explorer security option is turned off and your problem should go away.
0
Avatar
Legacy Poster
コメントアクション Permalink

I'm sorry, but I can't seem to see any attachments in your post or in this thread? Tried viewing in Chrome and IE.
0
Avatar
Legacy Poster
コメントアクション Permalink

Is something wrong with the forum? I still can't see the attachment you mentioned.
0
Avatar
Shotaro Ito
コメントアクション Permalink

Hi, Imranf,

Basically, you need to change registry key below's
HKEY_USERS\S-1-5-18\Software\Microsoft\Windows\CurrentVersion\WinTrust\Trust Providers\Software Publishing
value State from "00023c00" to "00023e00".

To create the registry patch, create a text file below, then rename to .reg file. (such as 1053.reg).

[code]
Windows Registry Editor Version 5.00

[HKEY_USERS\S-1-5-18\Software\Microsoft\Windows\CurrentVersion\WinTrust\Trust Providers\Software Publishing]
"State"=-

[HKEY_USERS\S-1-5-18\Software\Microsoft\Windows\CurrentVersion\WinTrust\Trust Providers\Software Publishing]
"State"=dword:00023e00
[/code]

To be safe, I recommend you to create restore point before apply registry change.
http://windows.microsoft.com/en-US/windows7/Create-a-restore-point

Then double click the .reg file to apply the change.

Please refer issues below as similar case:

www.symantec.com/business/support/index?page=content&id=TECH113477

digital.ni.com/public.nsf/allkb/18E25101F0839C6286256F960061B282
0
Avatar
Legacy Poster
コメントアクション Permalink

Hi,

 

I have recently installed BarTender 2016 R2 11.0.2.3056 X64 on a Windows 2008R2 x64 Enterprise SP1 server and activated it.

 

The service "BarTender Print Scheduler Service is running.

When i tried to stop and start the service i got error

"Windows could not start the service due to the following error: Windows could not find the file specified" !!!

 

I had kept an administrative installation so i copied the file to the path mentioned in the properties of the service in services.msc.

 

When i tried to start the service now i get error:

"Windows could not start the service due to te following error: The service could not start because it did no respond to the start or control request in a timely fashion.

 

i already tried the fix for error 1053 but that didnt help at all ( we are not connected to the internet..

 

please help me out.

Thank you

 

Matthijs Vossen

サインインしてコメントを残してください。