2019 Silent Install フォローする

0
Avatar
Jason Asbury

The silent install parameters dont seem to be working for 2019. I used the PDF on the support site, I added my BLS server and PKC key, but when I launch Bartender after it installs, it makes go through the license registration. I am using the example command listed on the PDF

setup.exe FEATURE=BarTender BLS=MyBLSServer:5160 PKC=xxxx-xxxx-xxxx-xxxx

18 コメント

0
Avatar
Jasper Wen
モデレータ
コメントアクション Permalink

Can you confirm if you are trying to install and activate BarTender 2019 on an initial system to host the license or BarTender clients on additional systems? Also, what version of Windows are you installing BarTender on?

I would suggest the following:

  • If you are installing and activating BarTender on an initial system to host the license, I would try running the command: setup.exe FEATURE=BarTender PKC=xxxx-xxxx-xxxx-xxxx without the BLS parameter since you wouldn't need to specify the License Server.
  • You would want to use the command: setup.exe FEATURE=BarTender BLS=MyBLSServer:5160 PKC=xxxx-xxxx-xxxx-xxxx to install and activate BarTender clients on additional systems.
  • If you are not installing our latest BarTender 2019 R2 at the moment, I would also suggest downloading and installing our latest release here.

If you are still running into issues, please contact us at support here so we can further assist you with this issue.

0
Avatar
Roel van Bueren
コメントアクション Permalink

I'm seeing different issues trying to deploy Bartender 2019 unattended.

I've downloaded 'https://d94r2itylgwnp.cloudfront.net/BarTender/11.1/BT2019_R4_140669_Full_x64.exe' from https://portal.seagullscientific.com/downloads

BT2019_R4_140669_Full_x64.exe is an MSI bootstrapper created using Advanced Installer. Per their documentation /exenoui would be the parameter to use to install unattended: https://www.advancedinstaller.com/user-guide/exe-setup-file.html.

However this doesn't work against BT2019_R4_140669_Full_x64.exe. Your documentation doesn't refer this switch altogether: https://www.bartendersoftware.com/media/1367/bartender-silent-install.pdf

Therefore I've extracted "BarTender.msi" from the 'BT2019_R1_135955_Full.exe' bootstrapper using the /extract switch.
Then using your documentation we've searched for the  BLS and PKC public properties to configure the license server (BLS) and product key code (PKC). But it seems these properties are not available in the MSI (anymore?).

Can you please provide more or update details about how to install Bartender 2019 unattended?

0
Avatar
Patrik Sjöblom
コメントアクション Permalink

We have the same problem in our enviroment using the latest Bartender exe installer.. BT2019_R5_144231_Full_x64

0
Avatar
Roel van Bueren
コメントアクション Permalink

Use these switches : FEATURE=BarTender INSTALLSQL=False

E.g.:

BT2019_R4_140669_Full_x64.exe FEATURE=BarTender INSTALLSQL=false
or
BT2019_R4_140669_Full.exe FEATURE=BarTender INSTALLSQL=false

0
Avatar
Patrik Sjöblom
コメントアクション Permalink

BT2019_R5_144231_Full_x64 FEATURE=BarTender INSTALLSQL=false doesn't work either.. It will only install ~340mb out of ~800mb. I have a supportcase opened for this.. SCCM uses system account for the install and somehow this doesn't work.

0
Avatar
Paul Rogero
コメントアクション Permalink

I've had similar troubles installing 2019 remotely. I've also tried with and without installing SQL and it does not make a difference in my case. I've also tried 32 and 64-bit installers but they give the same behavior.

I've used PDQ Deploy and a remote powershell session to run the installer but both of these give the same behavior. Installs about ~340MB of files as well.

I have a case open with tech support as well and they are looking into it.

0
Avatar
Patrik Sjöblom
コメントアクション Permalink

Any luck in this Paul? Any repsonse from tech support?

0
Avatar
Paul Rogero
コメントアクション Permalink

No definite fix yet. I'm going to work on installing SQL Server localdb first before the Bartender install and then use the InstallSql=false flag to see if that makes any difference.

0
Avatar
Eric G
コメントアクション Permalink

@Paul, Any update on this, i have been following as I am having the same issue installing with SCCM. As a required push using system context, it looks like it installs the SQL components and then just hangs. But when I make it an available install using the user context it installs everything successfully.

0
Avatar
Paul Rogero
コメントアクション Permalink

No update. Still cannot get the silent remote install to work. I can install from the command-line while logged in as a user with admin credentials. But cannot do so remotely. In our case the ‘remotely’ part is the most important part which I’m sure is the case for you as well. Tried installing SQL separately but still did not work.

0
Avatar
Mikhail Reznik
コメントアクション Permalink

Hi. I've  successfully silently installed BarTender 2019 with this command in SCCM:

BT2019_R6_147532_Full_x64.exe FEATURE=BarTender

But I need silent uninstall command too to make complete deployment. Can anyone help me?

1
Avatar
Jasper Wen
モデレータ
コメントアクション Permalink

Hi Mikhail,

I would suggest try using the following command for uninstalling BarTender 2019.

BT2019_R4_XXXXX_Full_x64.exe /qn REMOVE=ALL

The REMOVE=ALL parameter indicates to uninstall all components and the /qn parameter suggests to run the installer without visible windows.

0
Avatar
Mikhail Reznik
コメントアクション Permalink

Thank you Jasper!

It worked!

But I need one more thing. After installation of the BarTender shortcut doesn't appear on the desktop.  Our users think the app's not installed. How can I get the shortcut to appear on the desktop after installation?

0
Avatar
Joshua Abts
コメントアクション Permalink

@Paul and @Eric - any chance you guys are using redirected folders (specifically, redirected My Documents)?  We are and I have followed this through the install process to this being the issue.  If I change the registry key for HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders\Personal to be a local folder rather than a unc path, then the install completes and properly installs the full 800+mb install.  If I don't, it results in that ~340MB install without any of the actual applications.

I am using PDQ to deploy and have tried using a few steps to adjust the registry before doing the install, but even that isn't working.  if I set the installer to run "interactive" as the deploy user, then it installs the full install but still errors out and requires a manual repair of the application to be able to use it.

If there was a way to prevent the MSI from trying to actually install the "sample documents" I feel like I would get further, not sure if this is possibly the issue you are seeing as well?

0
Avatar
Paul Rogero
コメントアクション Permalink

We are using redirected folders including MyDocuments. What you've stumbled upon sounds promising. I've never been able to get it to work but have always had folder redirection enabled since that is how our environment is configured. I know of no way to turn off the sample documents feature but Seagull guys might know something.

0
Avatar
Joshua Abts
コメントアクション Permalink

Looks like we are in the same boat then with the redirected folders being the underlying issue.

What have you done as your work around?  Manual local installs of the application using a non-redirected user?  Or just running installs locally manually, and not doing remote installs?

0
Avatar
Paul Rogero
コメントアクション Permalink

I don't have any workaround. Manual local install is the only thing that has worked.

I didn't think to try installing remotely using a non-redirected user. May give that a try later to see what happens. Are you saying that worked for you?

0
Avatar
Joshua Abts
コメントアクション Permalink

Unfortunately, no, using a local non-redirected user also didn't work when running remotely/silently.

I have an open case that is getting escalated I believe with the full installer log to see if they can isolate what the issue is.

サインインしてコメントを残してください。