PrintPortal ODBC login フォローする

0
Avatar
Franklin Geiser

I've got a label setup that pulls data from a SQL database via a 64 bit System ODBC connection. 
It works great when printing from BarTender, but when I try to print from PrintPortal (either on the same computer that bartender is installed on, or a different one), I get "Print job aborted. the record set could not be created due to the following: a user name ad/or password was incorrect or missing"

Anybody have ideas on this?  Not sure what account PrintPortal uses to access ODBC (but it shouldn't matter either, since I have it setup as a System DSN)

3 コメント

0
Avatar
Jasper Wen
モデレータ
コメントアクション Permalink

Most likely Print Portal is not running with the proper permissions to access your database that you are pulling data from. You will most likely need to do the following:

  1. Open IIS (Internet Information Services) manager.
  2. Expand the left pane and go to the application pools.
  3. Find and right click on the BPP_AppPool that Print Portal uses.
  4. Go to advanced settings.
  5. Find and select the Identity setting.
  6. Click the "..."
  7. Set the identity to the custom account option and click the set button.
  8. Specify a domain account with proper permissions to access your database and run BarTender.
  9. Click ok to the dialogs and accept the changes until you back on the main IIS manager and application pools page.
  10. Right click on the BPP_AppPool application pool again and click recycle to restart the application pool and apply the changes.
0
Avatar
Franklin Geiser
コメントアクション Permalink

Hmm, sounds like a great solution, but unfortunately this didn't change anything for me.

I set the account to MYDOMAIN\administrator with the correct password and recycled, but no change.

0
Avatar
Franklin Geiser
コメントアクション Permalink

Here's an update that I received directly from tech support:

If it is a database engine that supports SQL Server credentials, I would advise trying to use the Microsoft SQL Server database connection instead of the ODBC database connection.  As a safety tip, save a copy of your template and try making this change to the copy so you have your original to go back to if it does not work.

Another workaround you may try is to start the Print Scheduler Service under a different Windows Account.  Go to the "Services" app from the Windows Start Menu to accomplish this.

 

The direct SQL connection didn't change anything, but changing the account for the print scheduler seems to have resolved this issue.

ログインしてコメントを残してください。