Issue with Aegis Factorylogix フォローする

0
Avatar
Jack Smith

Hello, 

Trying to link Bartender files to our MES (Aegis Factorylogix, which supports Bartender), and getting the following error. 

Does this look familiar to anyone? Running Bartender 2016 R7, Version 11.07.3146 64-Bit.

Thank you

===========================================================================================

Application Error

Could not load file or assembly 'Interop.BarTender, Version=10.0.2.1, Culture=neutral, PublicKeyToken=109ff779a1b4cbc7' or one of its dependencies. The system cannot find the file specified.

===================================

Could not load file or assembly 'Interop.BarTender, Version=10.0.2.1, Culture=neutral, PublicKeyToken=109ff779a1b4cbc7' or one of its dependencies. The system cannot find the file specified. (Seagull.BarTender.Print)

------------------------------
Program Location (Client side):

at Seagull.BarTender.Print.Engine.Dispose(Boolean bDisposeManaged)
at Seagull.BarTender.Print.Engine.Finalize()

 

2 コメント

0
Avatar
Pete Thane
コメントアクション Permalink

There are a couple of similar (older) posts about issues with the interopp dlls being incorrect., such as

https://support.seagullscientific.com/hc/en-us/community/posts/216559967-Could-Not-Load-File-Or-Assembly-39-interop-bartender-Version-10-0-0-0

I think the file your system if looking for is from an older version of BarTender (10.0?) and so may not be compatible with 2016 

 

0
Avatar
Al Perez
モデレータ
コメントアクション Permalink

Hi Jack, thanks for your post!

It looks like your MES software is using older assemblies (specifically BarTender 10.0, SR2), as Peter pointed out. Your best option here would be to reach out to Aegis and have the software recompiled using BarTender 2016's assemblies (in your case, 11.0.7).

If you do go this route, I highly suggest updating BarTender 2016 to the latest version first, which is R9 - you can download here (make sure you're selecting the correct version, it's easy to confuse it with BarTender 2019 R9). Once you have the latest build for your version, contact Aegis about getting your MES software updated as well.

Cheers!

サインインしてコメントを残してください。