Commander Serial Trigger 关注

0
Avatar
Legacy Poster

Hi,

I am trying to connect commander to a serial trigger. The port is set up correct. In a rs232 data logger, the data is correct. However in commanders trigger text file it only records the first three characters. What can be done to solve this issue.

3 评论

0
Avatar
Shotaro Ito
评论操作 固定链接

Hi Martin,
In Configure port > Serial port connection, make sure you have proper port setting.

For trigger event [Port Becomes Idle], make idle time longer - such as 1000ms.

For [Sequence of Characters received],  if you want to keep detection condition in trigger, enable [Include sequence in trigger contents].

0
Avatar
Legacy Poster
评论操作 固定链接

Hi,  

 

The port is set exactly as the data logger.  What is strange is sometimes it works and other times not.  This is without any changes.  The data stream does consist of special characters, could this be an issue?  I changed the encoding and the idle time up to 10000 ms.  Nothing changed.  If i run a virtual Serial port.  The data logger sees all the data.  Commander on the same port with the same settings does not.  

 

This is the stream:  6BBCH 28072015 2 029 2 028)  On here the special characters are dropped.  In commanders text file, only 3 of the special characters are received.  so not even the "6"

0
Avatar
Shotaro Ito
评论操作 固定链接

What is the data logger - is the data logger using windows's com port, such as Hercules SETUP utility?

Commander supposed to take data sequence even it has control codes. Does the received code includes nul (00H?)

Also if you can, try with another data sequence to find out the issue is caused by data sequence or connection method.

请先登录再写评论。